Welcome to the new Linux Foundation Forum!

Help: VM on Virtualbox Ubuntu 18. Can't even get Kubernetes installed due to dependencies Issues.

Hi,

I'm very new to Kubernetes. So I'm following the instructions from the manual you provided for the labs.
I'm on Ubuntu 18.04.2 LTS on VirtualBox.
I added the Xenial repo as asked. I can't even install kubernetes code:

[email protected]:/home/oracle# apt-get install kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kubeadm : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
kubelet : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
E: Unable to correct problems, you have held broken packages.

Comments

  • btanouebtanoue Posts: 59

    Note: I ran ready-for.sh and it says I'm good for the course.

  • serewiczserewicz Posts: 514

    Hello,

    First off I would suggest using Ubuntu 16 instead of 18 as there are some quirks that have yet to be sorted out.

    The second suggestion is to ensure you have run apt-get update, so that the repo information is current and can be used. Do you have issues installing any other software, or only the kubernetes packages? If it is only these packages ensure that the sources file you created has four distinct sections. A typical error is to miss a whitespace and the repo does not get used properly.

    Regards,

  • chrispokornichrispokorni Posts: 286

    Hi,
    With the release of a new Kubernetes version, lately, we noticed that prior versions are impacted in one way or another.
    Version 1.13.1 used for the labs was impacted by the kubernetes-cni package, where the current dependency is set to kubernetes-cni version 0.7.5 (the lates). Unfortunately, version 0.7.5 is not supported by our lab environment Kubernetes version 1.13.1, thus we need to manually install kubernetes-cni version 0.6.0 which is the supported version by Kubernetes 1.13.1.

    When going thru the installation steps, an additional installation needs to be completed before the Kubernetes version 1.13.1 components installation in Step 7.

    STEP 6:
    apt-get update

    STEP 7:
    apt-get install -y kubernetes-cni=0.6.0-00
    apt-get install -y kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00

    Also, make sure you are on Ubuntu 16.04 LTS, as instructed in STEP 4 and as mentioned by @serewicz in his comment above.

    Regards,
    -Chris

  • btanouebtanoue Posts: 59

    HI Serewicz,

    I installed 16.04.6 LTS and I'm getting the same error:

    [email protected]:/home/oracle# apt-get -y install kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kubeadm : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
    kubelet : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
    E: Unable to correct problems, you have held broken packages.

  • btanouebtanoue Posts: 59

    Chris,

    That worked! Thank You, Thank You, THANK YOU!

  • GaneshB.GGaneshB.G Posts: 3

    When i run ready-for.sh i see the below error, can someone help?

    ./ready-for.sh LFD420

    Checking that this computer is suitable for LFD420: Linux Kernel Internals and Debugging

    PASS: CPU architecture is x86_64
    PASS: 2 core CPU
    PASS: Your CPU appears powerful enough (currently at 11232 BogoMIPS cumulatively)
    PASS: 1 GiB RAM
    WARN: /home/vagrant only has 6 GiB free (need at least 9 GiB)
    PASS: However, BUILDHOME=/vagrant has 64 GiB free
    PASS: 6572 MiB free disk space in /boot
    PASS: Linux distribution architecture is x86_64

    NOTE: Currently running Ubuntu 16.04.5 LTS (supported)

    WARN: dpkg reports some issues with the package system. I can't continue without these being fixed.
    Is it okay if I try a "dpkg --configure -a"?
    Continue? [Yn] Y
    dpkg: error processing package unattended-upgrades (--configure):
    package is in a very bad inconsistent state; you should
    reinstall it before attempting configuration
    Errors were encountered while processing:
    unattended-upgrades

  • fcioancafcioanca Posts: 305

    @GaneshB.G LFD420 does not have a forum, as that is an instructor led course, and any issues will be discussed during the live course with the instructor. This forum is only for LFS258.

  • GaneshB.GGaneshB.G Posts: 3

    NVM, I could get it to work by doing update and upgrade.

  • coopcoop Posts: 301

    You should have been running ./ready-for.sh --install LFS258 anyway. Ubntu 16.04 is indeed unsupported for LFD420 but that is of no concern to you :)

Sign In or Register to comment.