Welcome to the new Linux Foundation Forum!

Help: VM on Virtualbox Ubuntu 18. Can't even get Kubernetes installed due to dependencies Issues.

Hi,

I'm very new to Kubernetes. So I'm following the instructions from the manual you provided for the labs.
I'm on Ubuntu 18.04.2 LTS on VirtualBox.
I added the Xenial repo as asked. I can't even install kubernetes code:

[email protected]:/home/oracle# apt-get install kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kubeadm : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
kubelet : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
E: Unable to correct problems, you have held broken packages.

Comments

  • btanouebtanoue Posts: 34

    Note: I ran ready-for.sh and it says I'm good for the course.

  • serewiczserewicz Posts: 467

    Hello,

    First off I would suggest using Ubuntu 16 instead of 18 as there are some quirks that have yet to be sorted out.

    The second suggestion is to ensure you have run apt-get update, so that the repo information is current and can be used. Do you have issues installing any other software, or only the kubernetes packages? If it is only these packages ensure that the sources file you created has four distinct sections. A typical error is to miss a whitespace and the repo does not get used properly.

    Regards,

  • chrispokornichrispokorni Posts: 219

    Hi,
    With the release of a new Kubernetes version, lately, we noticed that prior versions are impacted in one way or another.
    Version 1.13.1 used for the labs was impacted by the kubernetes-cni package, where the current dependency is set to kubernetes-cni version 0.7.5 (the lates). Unfortunately, version 0.7.5 is not supported by our lab environment Kubernetes version 1.13.1, thus we need to manually install kubernetes-cni version 0.6.0 which is the supported version by Kubernetes 1.13.1.

    When going thru the installation steps, an additional installation needs to be completed before the Kubernetes version 1.13.1 components installation in Step 7.

    STEP 6:
    apt-get update

    STEP 7:
    apt-get install -y kubernetes-cni=0.6.0-00
    apt-get install -y kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00

    Also, make sure you are on Ubuntu 16.04 LTS, as instructed in STEP 4 and as mentioned by @serewicz in his comment above.

    Regards,
    -Chris

  • btanouebtanoue Posts: 34

    HI Serewicz,

    I installed 16.04.6 LTS and I'm getting the same error:

    [email protected]:/home/oracle# apt-get -y install kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kubeadm : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
    kubelet : Depends: kubernetes-cni (= 0.6.0) but 0.7.5-00 is to be installed
    E: Unable to correct problems, you have held broken packages.

  • btanouebtanoue Posts: 34

    Chris,

    That worked! Thank You, Thank You, THANK YOU!

Sign In or Register to comment.