Welcome to the Linux Foundation Forum!

Lab 3.1.8 - podman not found

  1. sudo podman build -t simpleapp .

    sudo: podman: command not found

  2. sudo apt-get -y install podman

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package podman

I don't seem to have docker either.


  • serewicz
    serewicz Posts: 1,000


    Indeed Podman was removed upstream, for some reason. I had updated the labs to show a way to locate the binary, but then did something via git where I lost the update and instead inserted old lab steps. I think I have figured out what I did to the labs by accident and fixed it. I'll be pushing updates soon. Until then:
    Lab 3.1, somewhere around step 7:
    student@cp:˜/app1$ curl -fsSL -o podman-linux-amd64.tar.gz https://github.com/mgoltzsche/podman-static/releases/latest/download/podman-linux-amd64.tar.gz
    student@cp:˜/app1$ tar -xf podman-linux-amd64.tar.gz
    student@cp:˜/app1$ sudo cp -r podman-linux-amd64/usr podman-linux-amd64/etc /

    The US Thanksgiving holiday may delay the update rolling out, but I'm on it. Thank you for letting me know I messed up the previous.


  • tstaffordsmith

    Thank you @serewicz. That worked!

  • taepyongyang

    Thank you @serewicz! :)

  • dec698
    dec698 Posts: 6
    edited November 2022

    Hi @serewicz, so when you say "I'll be pushing updates soon" you mean when someone run the latest setup script, podman will be there?

  • ignace.hakizimana

    Hello @serewicz, Even this one does not work on my side. Any latest update on this?

  • chrispokorni

    Hi @ignace.hakizimana,

    The instructions in the earlier post work just as well as the instructions from the lab guide step 3.1.8.
    I attempted a clean podman installation and they both worked.

    I would encourage you to confirm that especially the first command is executed in its entirety. There are terminal applications which do not handle well multi-line commands, where backslashes "\" are used to separate lines of the same command. What is the OS of your host machine, and what terminal/ssh client are you using to access the lab VM?

    If still not successful, please provide a screenshot or paste in the forum the command and its outputs to help troubleshoot.



Upcoming Training