Welcome to the new Linux Foundation Forum!

Missing dependency for installing and using kubeadm, kubectl and kubelet

Hello,
There seems to be a dependency for installing the kubeadm, kubectl and kublet software. The version had been hard coded and now breaks as there is a newer version available. Force an install of the previous version and the install should work. This would be step "6.5" in the lab. apt-get install kubernetes-cni=0.6.0-00 Do this for both the master and worker nodes

Comments

  • AnujSinghAnujSingh Posts: 1

    Thanks,
    Lab_3.1.pdf - steps 7 worked with ->
    apt-get -y install kubeadm=1.13.1-00 kubelet=1.13.1-00 kubectl=1.13.1-00 kubernetes-cni=0.6.0-00

Sign In or Register to comment.