Welcome to the Linux Foundation Forum!

Lab 3.1 - Volume did not finish being create


Hi everyone

I have deployed devstack as per instructions in pdf, on Ubuntu 16.04, KVM with Ubuntu 16.04, 7 CPU and 12 GB of RAM and 40/100 GB disk
on my desktop and also on my laptop - almost identical setups.

I can log in OK, and as a admin i was able to create 1 vm.
During lab 3.1 i created additional user and tried to start another instance. On both setups it comes up with an error message:

Build of instance 4f0542bc-f53c-4686-95d2-cd37d8c82553 aborted: Volume 6731e568-1239-4bc1-a1e7-231979ddfd5a did not finish being created even after we waited 0 seconds or 1 attempts. And its status is error.

File "/opt/stack/nova/nova/compute/manager.py", line 1840, in do_build_and_run_instance filter_properties) File "/opt/stack/nova/nova/compute/manager.py", line 2028, in _build_and_run_instance phase=fields.NotificationPhase.ERROR, exception=e) File "/usr/local/lib/python2.7/dist-packages/oslo_utils/excutils.py", line 220, in exit self.force_reraise() File "/usr/local/lib/python2.7/dist-packages/oslo_utils/excutils.py", line 196, in force_reraise six.reraise(self.type, self.value, self.tb) File "/opt/stack/nova/nova/compute/manager.py", line 1984, in _build_and_run_instance block_device_mapping) as resources: File "/usr/lib/python2.7/contextlib.py", line 17, in enter return self.gen.next() File "/opt/stack/nova/nova/compute/manager.py", line 2173, in _build_resources reason=e.format_message())

I then tried logging back on as admin to test if its permission/quota or something else, but now i can not create new instance as a admin user either.
Tried googling but below solution did not resolve my problem.

I reviewed https://docs.openstack.org/devstack/latest/ to see if there are any additional specific options are reuired but i dont see any.

Anyone else saw or had similar issues?


  • kowalczykb

    so digging into errors now:

    $ sudo journalctl -f --unit devstack@c-vol
    ERROR cinder.service [-] Manager for service cinder-volume devstack1@lvmdriver-1 is reporting problems, not sending heartbeat. Service will appear "down".

    i do not seem to have service that error message is compaling about:
    $ sudo systemctl list-units | grep lvm
    lvm2-lvmetad.service loaded active running LVM2 metadata daemon
    lvm2-monitor.service loaded active exited Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
    lvm2-lvmetad.socket loaded active running LVM2 metadata daemon socket
    lvm2-lvmpolld.socket loaded active listening LVM2 poll daemon socket

  • serewicz
    serewicz Posts: 1,000


    Are you able to create and view a new volume from the command line using lvcreate and lvs? If you look in the cinder logs you should be able to find the actual command which failed, and try that as well as there are often other errors seen in the terminal when you run the command itself.

    It could be that you have a quota issue, or there is not enough disk space in the volume group. Other OpenStack issues could also be possible, but if you searched the various sites you would probably have found them.


  • kowalczykb

    Thank you Mr Serewicz. I figured out what it was... I rebooted the instance and was able to successfully replicate this behaviour. Devstack, unfortunately, doesn't survive this action(reboot). Should have remembered that from pdf where you mentioned it.. (Facepalm)

  • serewicz
    serewicz Posts: 1,000



Upcoming Training