Note on lab 7.4: "trivy image" instead of "trivy -i"
Hi,
just to share the knowledge that trivy image scan instructions in a lab need an update,
suggested command fails with trivy v0.22.0:
$ sudo trivy --debug -i nginx
2022-01-30T20:06:17.948+0200 WARN The root command will be removed. Please migrate to 'trivy image' command. See https://github.com/aquasecurity/trivy/discussions/1515
2022-01-30T20:06:17.948+0200 DEBUG Severities: UNKNOWN,LOW,MEDIUM,HIGH,CRITICAL
2022-01-30T20:06:17.972+0200 DEBUG cache dir: /root/.cache/trivy
2022-01-30T20:06:17.972+0200 DEBUG DB update was skipped because DB is the latest
2022-01-30T20:06:17.972+0200 DEBUG DB Schema: 1, Type: 1, UpdatedAt: 2022-01-30 12:43:56.950700956 +0000 UTC, NextUpdate: 2022-01-30 18:43:56.950700556 +0000 UTC, DownloadedAt: 2022-01-30 17:46:26.104052182 +0000 UTC
2022-01-30T20:06:17.972+0200 DEBUG Vulnerability type: [os library]
2022-01-30T20:06:17.973+0200 FATAL scan error:
github.com/aquasecurity/trivy/pkg/commands/artifact.runWithTimeout
/home/runner/work/trivy/trivy/pkg/commands/artifact/run.go:71
- unable to initialize a scanner:
github.com/aquasecurity/trivy/pkg/commands/artifact.scan
/home/runner/work/trivy/trivy/pkg/commands/artifact/run.go:211
- unable to initialize the archive scanner:
github.com/aquasecurity/trivy/pkg/commands/artifact.archiveScanner
/home/runner/work/trivy/trivy/pkg/commands/artifact/image.go:21
- 2 errors occurred:
* unable to open nginx as a Docker image: unable to open the file: open nginx: no such file or directory
* unable to open nginx as an OCI Image: stat nginx/index.json: no such file or directory
As pointed out https://github.com/aquasecurity/trivy/discussions/1515 this works:
$ sudo trivy image nginx
Comments
-
...copy/pasted a wrong failed command, here it is:
$ ls -lha nginx.tar
-rw-rw-r-- 1 yurick yurick 264M Jan 30 19:51 nginx.tar$ sudo trivy -i nginx.tar
2022-01-30T20:15:23.160+0200 WARN The root command will be removed. Please migrate to 'trivy image' command. See https://github.com/aquasecurity/trivy/discussions/1515
2022-01-30T20:15:23.246+0200 FATAL scan error: unable to initialize a scanner: unable to initialize the archive scanner: 2 errors occurred:
* unable to open nginx.tar as a Docker image: tarball must contain only a single image to be used with tarball.Image
* unable to open nginx.tar as an OCI Image: stat nginx.tar/index.json: not a directoryPlease let me know if I understood it wrong and local images can be still scanned somehow even with the latest trivy.
0
Categories
- All Categories
- 179 LFX Mentorship
- 179 LFX Mentorship: Linux Kernel
- 776 Linux Foundation IT Professional Programs
- 384 Cloud Engineer IT Professional Program
- 175 Advanced Cloud Engineer IT Professional Program
- 76 DevOps IT Professional Program - Discontinued
- 7 DevOps & GitOps IT Professional Program
- 103 Cloud Native Developer IT Professional Program
- 7.7K Training Courses & Learning Paths
- 16 AI & ML Training
- 1 Blockchain & Decentralized Identity Training
- 42 Cloud & Containers Training
- 6 Cybersecurity Training
- 4 DevOps & Site-Reliability Training
- 3 Linux Kernel Development Training
- 2 Networking Training
- 2 Open Source Best Practice Training
- 6 System Administration Training
- 1 System Engineering Training
- 6 Web & Application Development Training
- 798 Hardware
- 202 Drivers
- 68 I/O Devices
- 37 Monitors
- 96 Multimedia
- 173 Networking
- 91 Printers & Scanners
- 92 Storage
- 774 Linux Distributions
- 82 Debian
- 68 Fedora
- 24 Linux Mint
- 13 Mageia
- 24 openSUSE
- 151 Red Hat Enterprise
- 32 Slackware
- 13 SUSE Enterprise
- 356 Ubuntu
- 473 Linux System Administration
- 31 Cloud Computing
- 73 Command Line/Scripting
- Github systems admin projects
- 104 Linux Security
- 79 Network Management
- 102 System Management
- 46 Web Management
- 173 Mobile Computing
- 32 Android
- 126 Development
- 1.2K New to Linux
- 1K Getting Started with Linux
- 407 Off Topic
- 128 Introductions
- 35 Study Material
- 1.1K Programming and Development
- 311 Kernel Development
- 728 Software Development
- 1K Software
- 421 Applications
- 183 Command Line
- 5 Compiling/Installing
- 71 Games
- 320 Installation
- Archived
- 183 Small Talk
- 2 LFD140 Class Forum
- 1.4K LFS258 Class Forum
Upcoming Training
-
August 20, 2018
Kubernetes Administration (LFS458)
-
August 20, 2018
Linux System Administration (LFS301)
-
August 27, 2018
Open Source Virtualization (LFS462)
-
August 27, 2018
Linux Kernel Debugging and Security (LFD440)