Welcome to the Linux Foundation Forum!

Lab 5.2. Make OpenSSH Client Configuration Changes | LFS211

Hi there,

I'm doing the lab from the subject line on this post but when I do ssh garply and input the root password, I get Permission denied, please try again, even though I'm putting the correct root password.

I found this possible solution on this post but after doing all the steps (without any errors), I still get the permission denied issue:

[[email protected] ~]$ sudo su -c 'cat /home/carlos/.ssh/authorized_keys >> /root/.ssh/authorized_keys '
[[email protected] ~]$ sudo chown root.root /root/.ssh/authorized_keys
[[email protected] ~]$ sudo chmod 600 /root/.ssh/authorized_keys
[[email protected] ~]$ ssh garply

I have to mention that I had to create an authorized_keys file and move id-rsa.pub to it (I'm mentioning it since it wasn't on the instructions nor an authorized_keys files was created when generating the SSH keys).

This is my $HOME/.ssh/config file:

host garply
hostname localhost
user root

host *
ForwardX11 yes

This is the output of ls -l $HOME/.ssh/config:

rw------- 1 carlos carlos 64 ene 11 10:57 /home/carlos/.ssh/config

And PermitRootLogin is set to yes on `/etc/ssh/sshd_config

Any help would be very much appreciated!

Cheers.

Answers

  • Solved it by deleting everything that I'd done and starting from scratch plus the solution from the post I quoted on my initial thread

  • lee42x
    lee42x Posts: 351

    Thank you for the observation.

    The lab was verified. The only challenge is the default value for PermitRootLogin a mentioned in the Please Note in the beginning of chapter 5.1. The lab will be modified to integrate setting the PermitRootLogin into the lab as the defaults have changed in the distributions.

    Thank you for your input.

Categories

Upcoming Training