Welcome to the Linux Foundation Forum!

Lab 9.2 connection issue

Lab 9.2, point 5.
When I run mutt -f imap://[email protected]/ I get a message in mutt that, "could not connect to localhost (connection refused)".

If I log in as the student user, and run mutt, the emails are there.

I've stopped and disabled firewalld, added the student to the mail group, and it's a fresh install of ubuntu18 so I don't think the server is set up with a dummy SSL certificate. If it is, how do I deal with that?

Otherwise, why I am getting this error?

Thanks in advance.

Comments

  • lee42x
    lee42x Posts: 361

    Verify that "dovecot" is running. Running mutt as a student locally does not use dovecot for communication it access the files directly. Using the "mutt -f imap://[email protected]" forces a connection through dovecot.

    There should be a listener on the ports 143 and/or 993

    [email protected]:/tmp$ netstat -taupn | grep -e 143 -e 993
    tcp6 0 0 :::143 :::* LISTEN -
    tcp6 0 0 :::993 :::* LISTEN -
    l

  • gairsty
    gairsty Posts: 26

    Hi Lee.

    In order to make this section work I had to:
    modify ssl = noin /etc/dovecot/conf.d/10-ssl.conf, and I commented out
    ssl_cert = </etc/dovecot/private/dovecot.pem
    ssl_key = </etc/dovecot/private/dovecot.key
    Which gets dovecot to run, and then I am able to mutt -f etc etc.

    I was just about to try putting in the ssl certs from lab 7.5, as , "you can use the same certificates for
    Apache and Dovecot." when I noticed the next lab was about SSL.

    Once again, frustrated that following the instructions does not give me the results I'm told to expect. Particularly as there are errors in Lab 9.3.

  • lee42x
    lee42x Posts: 361

    Thank you for your observations. Dovecot no longer accepts imap (clear text) if "ssl = yes" is enabled. The default seems to have been switched to "ssl = yes " . This lab will need an additional step to disable ssl while file locations, permissions and listeners are sorted, then in the next section enable ssl.

    Thank you for your input.
    Lee

  • k0dard
    k0dard Posts: 115

    Hello,

    I'm posting here because I've ran onto the same problem but after changing /etc/dovecot/conf.d/10-ssl.conf (ssl = no) when trying to connect with mutt -f imap://[email protected] I get Encrypted connection unavailable

    dovecot is listening on 143

    telnet localhost imap
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.

    • OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE LITERAL+ AUTH=PLAIN] Dovecot (Ubuntu) ready.

    When setting ssl = required, mutt is connecting, so I guess I need to disable something else but I don't know what in order to connect without ssl

    Can someone please help ?

    Thanks in advance

  • @gairsty said:
    Hi Lee.

    In order to make this section work I had to:
    modify ssl = noin /etc/dovecot/conf.d/10-ssl.conf, and I commented out
    ssl_cert = </etc/dovecot/private/dovecot.pem
    ssl_key = </etc/dovecot/private/dovecot.key
    Which gets dovecot to run, and then I am able to mutt -f etc etc.

    I was just about to try putting in the ssl certs from lab 7.5, as , "you can use the same certificates for
    Apache and Dovecot." when I noticed the next lab was about SSL.

    Once again, frustrated that following the instructions does not give me the results I'm told to expect. Particularly as there are errors in Lab 9.3.

    I'm also having issues with this one. Even after doing the above and turning off SELinux, it still says: [NOPERM] Permission denied (0.001 + 0.000 secs).

    /var/log/maillog says:

    Feb 21 23:45:17 ip-172-31-37-51 dovecot: imap-login: Login: user=<def>, method=PLAIN, rip=::1, lip=::1, mpid=4547, secured, session=<kTANR+G7Dq8AAAAAAAAAAAAAAAAAAAAB>
    Feb 21 23:45:19 ip-172-31-37-51 dovecot: imap(def): Logged out in=70 out=975
    

Categories

Upcoming Training