Welcome to the Linux Foundation Forum!

LFS258 Lab 3.1 #14

When I am running

kubeadm init --config=kubeadm-config.yaml --upload-certs | tee kubeadm-init.out

I am getting command not found. I run all command up to #13 successfully.

Thanks

Comments

  • chrispokornichrispokorni Posts: 631
    edited July 5

    Hi @cziaul,

    You would receive the "command not found" message when the Kubernetes components, kubeadm, kubelet, and kubectl, have not been successfully installed.
    I'd recommend revisiting steps 5, 6, 7, and 8.
    After executing step 5, run cat /etc/apt/sources.list.d/kubernetes.listand compare the output with the lab exercise.
    For step 6, running the command as a single-liner may help, because some CLI tools do not play nicely with multi-line commands: curl -s https://packages.cloud.google.com/apt/doc/apt-key.gpg | apt-key add -
    After the first command in step 8, where you install the Kubernetes components, verify with which kubeadm to make sure it was installed. If the install was successful it will output the path where the binary has been installed on the system. No response of any kind means that it did not get installed.

    Regards,
    -Chris

  • cziaulcziaul Posts: 27

    Hi Chris, Thanks for your ans. since I posted this post yesterday and didn't get ans so I totally use my worker as master and run through all command but getting below error now

    Found multiple CRI sockets, please use --cri-socket to select one: /var/run/dockershim.sock, /var/run/crio/crio.sock
    To see the stack trace of this error execute with --v=5 or higher

    Since I have gone though all command again, I kept screen shot for all the output, attached herewith doc file.

    I would appreciate your early repose since already wasted almost 2 days

  • fcioancafcioanca Posts: 553
    edited July 5

    @cziaul Responses can take up to 2 business days (no weekends or holidays included), therefore we appreciate your understanding and patience.

  • cziaulcziaul Posts: 27

    @fcioanca please don't take it otherwise, here wasted means, I tried several times and couldn't succeed :-)

  • chrispokornichrispokorni Posts: 631

    Hi @cziaul,

    Thanks for the detailed info provided. To resolve the cri-socket conflict, you can supply the additional flag on step 4.x as: --cri-socket= /var/run/crio/crio.sock

    One concerning aspect of your Kubernetes nodes setup is the IP addresses of your nodes overlapping the Pod network IP range 192.168.0.0/16 supplied and managed by Calico. This is encountered often when working with VirtualBox and will lead to DNS issues in later lab exercises. With Kubernetes, you would want to have separate/non-overlapping networks for cluster nodes and the Pods.

    Regards,
    -Chris

  • cziaulcziaul Posts: 27

    I tried above but looks like still having same problem, so I created account at gcp and it started working.

  • serewiczserewicz Posts: 756

    Great! As Chris said often this issue is due to overlap or other host-based issue. Glad its working with GCE.

Sign In or Register to comment.