Welcome to the Linux Foundation Forum!

LFS258 - New course version now live! (updated labs)

fcioanca
fcioanca Posts: 989
edited January 2018 in LFS258 Class Forum

Hi,

We have updated the labs LFS258 this afternoon to work with Kubernetes v1.9.1. Please clear your cache to ensure you have access to the latest updates.

Updates to the course content are coming in about 6 weeks.

Regards,

Flavia

The Linux Foundation Training Team

Comments

  • mixpix3ls
    mixpix3ls Posts: 1
    edited January 2018

    Great timing Flavia! I just started this course tonight!

  • schotlandzegtja
    schotlandzegtja Posts: 2
    edited January 2018

    Hey Flavia,

    Lab 6.1 asks you to create a ReplicaSet from the text specified in the PDF. Unfortunately when you try to run it you get this error:


    ➜ kubectl create -f rs.yaml The ReplicaSet "rs-one" is invalid: * spec.selector: Required value * spec.template.metadata.labels: Invalid value: map[string]string{"system":"ReplicaOne"}: `selector` does not match template `labels`

    It would appear that you can no longer reply on an implicit selector, so you must specify it explicitly. It would be great if you could update the course material to reflect this for anyone running 1.9.2. Here is a patch of the broken manifest as in the lab, and the one I corrected. 


    --- rs.yaml 2018-01-29 18:39:32.000000000 +0100 +++ rs_2.yaml 2018-01-29 18:45:21.000000000 +0100 @@ -4,9 +4,6 @@ name: rs-one spec: replicas: 2 - selector: - matchLabels: - system: ReplicaOne template: metadata: labels:

    Thanks!

    Ross

  • serewicz
    serewicz Posts: 970

    Hello Ross,

    Thank you for the update.  We will reference your note when updating the course. As of now the course will update when the exam updates, to whichever version declared by CNCF. 

    Did you find this issue when running v1.9.1?

    Regards,

     

  • Hi serewicz,

    I haven't tried it but it's part of the 1.8 to 1.9 changes, so it will affect 1.9.1 too I am sure (see "Default selectors are deprecated" https://kubernetes.io/docs/reference/workloads-18-19/).



    Further, please see Lab 6.3. At step 1, the learner expects the DaemonSet to be using an 'OnDelete' updateStrategy, but as per the 1.8 to 1.9 changes, the updateStrategy value for all kinds defaults to RollingUpdate, thereby ruining the rest of the lab (see https://kubernetes.io/docs/reference/workloads-18-19/ "Default rolling updates").

    Has anyone reviewed the course material since the exam was upgraded?

    Thanks,

    Ross

Categories

Upcoming Training