Welcome to the new Linux Foundation Forum!

Lab 3.1

I am using the lastest version of Fedora in a Virtual Box. Once, I press "e" during the boot process, I do not see any line where I can append 3 to boot in non-graphical mode.

Can someone help me out?

Comments

  • MarcNCMarcNC Posts: 4
    sorry about the typo. I meant "latest" of course
  • coopcoop Posts: 260
    Make sure your keyboard is being captured by VirtualBox; does it work at all?
    Can you navigate up and down to pick different kernels? IF so thats fine, I am misunderstanding whether you can edit at all.

    Once you get in you have to edit aline that has root=... for the kernel you are choosing. On a redhat/fedora type system, that should be a line that starts with
    linux16 /boot/vmlinuz-....... This line will be followed by a line that starts with initrd16 ...
    (Depending on distro and version it might be linux or initrd, not linux16 or initrd16


  • MarcNCMarcNC Posts: 4
    coop wrote:
    Make sure your keyboard is being captured by VirtualBox; does it work at all?
    Can you navigate up and down to pick different kernels? IF so thats fine, I am misunderstanding whether you can edit at all.

    Once you get in you have to edit aline that has root=... for the kernel you are choosing. On a redhat/fedora type system, that should be a line that starts with
    linux16 /boot/vmlinuz-....... This line will be followed by a line that starts with initrd16 ...
    (Depending on distro and version it might be linux or initrd, not linux16 or initrd16


    Thank you. The keyboard works fine and I can navigate. I just can't find the /boot/vmlinuz line

    I attached a screenshot
  • coopcoop Posts: 260
    the screenshot did not show up for some reason.

    To get a better grasp, look at /boot/grub2/grub.cfg while the system is running and you should see the kernel command lines in there.
  • ElyasElyas Posts: 28
    Maybe you are not doing it right.

    In order to access GRUB bootloader do the following. It works in my case. Using Ubuntu in a Virtualbox on a Mac:

    - when the Virtualbox starts with the start screen, press Shift and keep your mouse clicked on that screen. This should show you GRUB bootloader.
    - You should see the bootloader displaying some options to choose from. Often it looks like a normal boot option, a rescue boot option and maybe one or two Memtest options. Use the arrow keys to navigate to the option you want to choose.
    - Press 'e' key on that option and you should see a screen with some command lines.
    - That is where you can modify the boot options.

    Please let us know if it worked for you.
  • MarcNCMarcNC Posts: 4
    Problem solved. It had to do with my Virtual Box boot order that nest a bunch of If and else statements and therefore kind of made it hard to find the right line with root and vmlinuz. I appended 3 after the Fedora version and the x86 and it worked. Thank you all!

    Great community. Long live the Linux Foundation and big thanks to Dr. Cooperstein, Elyas and everyone else at Linux
Sign In or Register to comment.