Welcome to the Linux Foundation Forum!

Spinnaker installation fails (sept 22)

Hi all,

Since I am not sure to have seen the problem below in the other posts, here is my issue

Minnaker installation failed with the log below, at the step ./scripts/install.sh -o --branch master -P

There are several errors so it is difficult to identify which is the real one, preventing the namespace "spinnaker" to be created in k3s

Thank you for your help

Laurent

[email protected]:~/minnaker-0.1.3# ./scripts/install.sh -o --branch master -P <my_public_ip>

[INFO ] Using OSS Spinnaker
[INFO ] Using OSS Spinnaker
[INFO ] Running minnaker setup for Linux
[INFO ] Cloning repo: https://github.com/armory/spinnaker-kustomize-patches#master into /root/minnaker-0.1.3/spinsvc
Cloning into '/root/minnaker-0.1.3/spinsvc'...
remote: Enumerating objects: 1816, done.
remote: Counting objects: 100% (502/502), done.
remote: Compressing objects: 100% (231/231), done.
remote: Total 1816 (delta 327), reused 378 (delta 265), pack-reused 1314
Receiving objects: 100% (1816/1816), 523.18 KiB | 8.72 MiB/s, done.
Resolving deltas: 100% (1042/1042), done.
[INFO ] Installing yq
[INFO ] Installing jq
[INFO ] Trying to detect endpoint
[INFO ] Using provided public IP 34.79.109.249
[INFO ] Generating password [/root/minnaker-0.1.3/spinsvc/secrets/spinnaker_password]:
<a secret>
[INFO ] Updating spinsvc templates with new endpoint: <my hidden ip>
Error: stat /root/minnaker-0.1.3/spinsvc/core_config/patch-version.yml: no such file or directory
[INFO ] Creating spin_endpoint helper function
#!/bin/bash
#echo "$(kubectl get spinsvc spinnaker -n spinnaker -ojsonpath='{.spec.spinnakerConfig.config.security.uiSecurity.overrideBaseUrl}')"
echo "$(yq e '.spec.spinnakerConfig.config.security.uiSecurity.overrideBaseUrl' BASE_DIR/expose/patch-urls.yml)"
[[ -f BASE_DIR/secrets/spinnaker_password ]] && echo "username: 'admin'"
[[ -f BASE_DIR/secrets/spinnaker_password ]] && echo "password: '$(cat BASE_DIR/secrets/spinnaker_password)'"
[INFO ] --- Installing K3s ---
[INFO]  Using v1.19.7+k3s1 as release
[INFO]  Downloading hash https://github.com/k3s-io/k3s/releases/download/v1.19.7+k3s1/sha256sum-amd64.txt
[INFO]  Downloading binary https://github.com/k3s-io/k3s/releases/download/v1.19.7+k3s1/k3s
[INFO]  Verifying binary download
[INFO]  Installing k3s to /usr/local/bin/k3s
[INFO]  Skipping installation of SELinux RPM
[INFO]  Creating /usr/local/bin/kubectl symlink to k3s
[INFO]  Creating /usr/local/bin/crictl symlink to k3s
[INFO]  Creating /usr/local/bin/ctr symlink to k3s
[INFO]  Creating killall script /usr/local/bin/k3s-killall.sh
[INFO]  Creating uninstall script /usr/local/bin/k3s-uninstall.sh
[INFO]  env: Creating environment file /etc/systemd/system/k3s.service.env
[INFO]  systemd: Creating service file /etc/systemd/system/k3s.service
[INFO]  systemd: Enabling k3s unit
Created symlink /etc/systemd/system/multi-user.target.wants/k3s.service → /etc/systemd/system/k3s.service.
[INFO]  systemd: Starting k3s
[INFO ]  --- END K3s --- 
[INFO ] Setting Kubernetes context to Spinnaker namespace
Context "default" modified.
[INFO ] Spinnaker Operator Version: 
[INFO ] Spinnaker flavor: oss
grep: spinnakerservice.yml: No such file or directory
[INFO ] Changing spinnaker flavor...Done
[ERROR] "kubectl kustomize ." returned an error:
Error: json: unknown field "components"
json: unknown field "components"
[KUBE ] kubectl apply -f https://engineering.armory.io/manifests/pacrd-1.0.1.yaml -n spinnaker
[ERROR] Error executing command:
Warning: apiextensions.k8s.io/v1beta1 CustomResourceDefinition is deprecated in v1.16+, unavailable in v1.22+; use apiextensions.k8s.io/v1 CustomResourceDefinition
Error from server (NotFound): error when creating "https://engineering.armory.io/manifests/pacrd-1.0.1.yaml": namespaces "spinnaker" not found
Error from server (NotFound): error when creating "https://engineering.armory.io/manifests/pacrd-1.0.1.yaml": namespaces "spinnaker" not found
Error from server (NotFound): error when creating "https://engineering.armory.io/manifests/pacrd-1.0.1.yaml": namespaces "spinnaker" not found
Error from server (NotFound): error when creating "https://engineering.armory.io/manifests/pacrd-1.0.1.yaml": namespaces "spinnaker" not found
Error from server (NotFound): error when creating "https://engineering.armory.io/manifests/pacrd-1.0.1.yaml": namespaces "spinnaker" not found

Comments

  • I have taken a note of this error. Will recreate the error and report further on the solution.

  • Thank you Gourav. If it can help I have tried to launch the script with the "minnaker" branch instead of "master" (which is 2 years old, so closer to the minnaker reporitory age on github). It failed the same way. If I try to create manually the "spinnaker" namespace and relaunch the script then we reach the "watch" command, looping with an error on 'spinsvc' object type that does not exist

Categories

Upcoming Training