Welcome to the Linux Foundation Forum!

Why "perf report" does not show function names in the second run, when used in docker?

I am trying to profile ffmpeg using the Linux perf command in docker. In the first run, the output is fine with all function names displayed by "perf report". In the second run, it only shows addresses rather than function names. I am using a script that runs the ffmpeg twice in a docker.

More details are posted here.

Thank you in advance.

Answers

  • akovi
    akovi Posts: 16

    When such outputs are produced, it is usually the result of not having access to the debug info. The second output actually shows that the object files are deleted, that is, they are not accessible. I'm not sure what you are trying to do here but ensure that you run the perf report in the docker container, instead of on the host machine. Maybe add the perf report commands to your script.

  • lfuserr
    lfuserr Posts: 5
    edited March 15

    Hi,

    Thank you for your reply.

    I ran perf report after perf record both in the container. The debug info should be in the shared objects as they are compiled with -g. When I use the verbose option for perf record, in the first iteration it shows correct mapping:

    Map: 558769917000-55876ba21000 0 /usr/local/bin/ffmpeg
    Map: 7f8c7bf84000-7f8c7c327000 0 /usr/local/lib/libx264.so.148

    But for the second iteration, it shows:

    Map: 5614337be000-5614358c8000 0 / (deleted)
    Map: 7ffa54f17000-7ffa552ba000 0 / (deleted)

    There are many other shared objects printed by perf record in "Map...", which I don't show to keep it short. They are also there for both iterations, that is, they are not deleted.

    What is weird is that I don't delete anything between the first and second iteration of running perf record then perf report. After perf report I use "ls ..." and it shows the objects have not been deleted. I don't know who deletes them or it might be a bug in the tool that prints "deleted". I don't know where to look into, perf or docker. I tried many many things, but I still could not find the root cause of this issue.

    When I ran my script on host, it works perfectly fine for both iterations.

    Again, thank you for your reply and time.

  • akovi
    akovi Posts: 16

    Can you post your full script that reproduces the error? I'd try it locally.

  • lfuserr
    lfuserr Posts: 5

    Hi,
    The experiment involves many components such as a docker image, installed packages, etc. I don't know how we can do it in an efficient way.

  • lfuserr
    lfuserr Posts: 5

    I will try to come up with an MRE, then I will let you know.

  • serewicz
    serewicz Posts: 994

    Hello,

    I think if you dig into what is happening you'll see where it diverges. Probably something to do with a cache, or an undocumented feature. If you use strace for each command how do they differ in what is done and referenced?

    Regards,

Categories

Upcoming Training