Welcome to the Linux Foundation Forum!

Getting error :setfacl: /home/ubuntu/.local: No such file or directory

Options

Answers

  • chrispokorni
    Options

    Hi @mangeshbelwalkar,

    What OS are you using to run the labs, in a virtual machine or native installation?
    What ID is used to run the lab exercise, what are the outputs of echo $HOME and ls -a $HOME commands?

    Regards,
    -Chris

  • dalbaran
    Options

    hi, I´m facing the same issue, I´m using a VM with ubuntu server (host is Windows 10)
    I tried to solve it creating the /.local directory but when I tried to start the container it failed (not sure if this error is the cause of the issue)

    find below the output of the commands requested:

  • terrence
    terrence Posts: 2
    Options

    I'm facing this same issue as well. I'm using a VM with Ubuntu Server (Host OS is Windows 10)
    see the outputs of the commands
    echo $HOME and ls -a $HOME

  • terrence
    terrence Posts: 2
    Options

    Hi everyone, so here's an explanation and a solution to this.

    Explanation

    In current Unix OS, /usr is where user-land programs and data (as opposed to 'system land' programs and data) are stored.
    The /usr/local directory mirrors the structure of the /usr directory, but can be used by system administrators to install local or third party packages for all users.
    ~/.local which is the same as /home/<user>/.local is made to mirror /usr/local directory but can be used by a partictular user to install local or third party packages for this particular user. This directory is often created by 3rd party applications/packages on the host OS.

    Solution

    Steps

    • In my case, I simply installed pip3 with sudo apt install python3-pip
      Related files to this package where installed to /usr

    • I installed a random package using pip3 install --user ipython
      This installs ipython for my particular user, so it automatically creates a .local directory in my home directory where folders and files related to this package are stored.

    I hope this helps :-)

  • chrispokorni
    chrispokorni Posts: 2,199
    Options

    Hi @dalbaran and @terrence,

    The ~/.local directory (if missing) can easily be created with mkdir .local.

    If the lxc-start command does not run the container upon creation with lxc-create (which seems to be an unexpected behavior), I recommend a reboot of the VM. After the VM reboot the container started successfully.

    Regards,
    -Chris

  • eerojin
    eerojin Posts: 1
    Options

    I have found the same issue. I have created the directory manually, and rebooted the VM.

    I'm running 24.04 LTS in VirtualBox.
    Any further suggestions would be appreciated.

  • chrispokorni
    chrispokorni Posts: 2,199
    Options

    Hi @eerojin,

    Such a recent release of the guest OS is not yet recommended for the lab environment.

    The lab guide is calling for an earlier and more stable version of the guest OS, please install the recommended release to ensure consistency in lab exercise behavior.

    Regards,
    -Chris

Categories

Upcoming Training