Welcome to the Linux Foundation Forum!

Lab 4.1 step 7: $sudo kubeadm upgrade plan

[upgrade/config] FATAL: this version of kubeadm only supports deploying clusters with the control plane version >= 1.20.0. Current version: v1.19.1
To see the stack trace of this error execute with --v=5 or higher

HOW CAN I UPGRADE CP V1.19.1 TO CP V1.20.0?

Answers

  • serewicz
    serewicz Posts: 971

    Hello,

    What version of the course are you using? The current labs would direct you to start with 1.20 and then upgrade to 1.21.

    What version of kubectl, kubeadm, and kubelet are you using? What command did you run to generate the error?

    Regards,

  • Bertpuit
    Bertpuit Posts: 4

    $sudo kubeadm version
    kubeadm version: &version.Info{Major:"1", Minor:"21", GitVersion:"v1.21.2", GitCommit:"092fbfbf53427de67cac1e9fa54aaa09a28371d7", GitTreeState:"clean", BuildDate:"2021-06-16T12:57:56Z", GoVersion:"go1.16.5", Compiler:"gc", Platform:"linux/amd64"}

    $sudo kubectl version
    Client Version: version.Info{Major:"1", Minor:"19", GitVersion:"v1.19.1", GitCommit:"206bcadf021e76c27513500ca24182692aabd17e", GitTreeState:"clean", BuildDate:"2020-09-09T11:26:42Z", GoVersion:"go1.15", Compiler:"gc", Platform:"linux/amd64"}
    Server Version: version.Info{Major:"1", Minor:"19", GitVersion:"v1.19.1", GitCommit:"206bcadf021e76c27513500ca24182692aabd17e", GitTreeState:"clean", BuildDate:"2020-09-09T11:18:22Z", GoVersion:"go1.15", Compiler:"gc", Platform:"linux/amd64"}

    $ sudo kubelet --version
    Kubernetes v1.19.1

    Command typed in was:

    ~$ sudo kubeadm upgrade plan
    [upgrade/config] Making sure the configuration is correct:
    [upgrade/config] Reading configuration from the cluster...
    [upgrade/config] FYI: You can look at this config file with 'kubectl -n kube-system get cm kubeadm-config -o yaml'
    [upgrade/config] FATAL: this version of kubeadm only supports deploying clusters with the control plane version >= 1.20.0. Current version: v1.19.1
    To see the stack trace of this error execute with --v=5 or higher

  • Bertpuit
    Bertpuit Posts: 4

    $sudo kubeadm version
    kubeadm version: &version.Info{Major:"1", Minor:"21", GitVersion:"v1.21.2", GitCommit:"092fbfbf53427de67cac1e9fa54aaa09a28371d7", GitTreeState:"clean", BuildDate:"2021-06-16T12:57:56Z", GoVersion:"go1.16.5", Compiler:"gc", Platform:"linux/amd64"}

    $sudo kubectl version
    Client Version: version.Info{Major:"1", Minor:"19", GitVersion:"v1.19.1", GitCommit:"206bcadf021e76c27513500ca24182692aabd17e", GitTreeState:"clean", BuildDate:"2020-09-09T11:26:42Z", GoVersion:"go1.15", Compiler:"gc", Platform:"linux/amd64"}
    Server Version: version.Info{Major:"1", Minor:"19", GitVersion:"v1.19.1", GitCommit:"206bcadf021e76c27513500ca24182692aabd17e", GitTreeState:"clean", BuildDate:"2020-09-09T11:18:22Z", GoVersion:"go1.15", Compiler:"gc", Platform:"linux/amd64"}

    $ sudo kubelet --version
    Kubernetes v1.19.1

    Command typed in was:

    $ sudo kubeadm upgrade plan
    [upgrade/config] Making sure the configuration is correct:
    [upgrade/config] Reading configuration from the cluster...
    [upgrade/config] FYI: You can look at this config file with 'kubectl -n kube-system get cm kubeadm-config -o yaml'
    [upgrade/config] FATAL: this version of kubeadm only supports deploying clusters with the control plane version >= 1.20.0. Current version: v1.19.1
    To see the stack trace of this error execute with --v=5 or higher

  • I faced similar issue - whats the solution ?

    kubeadm upgrade plan
    [upgrade/config] Making sure the configuration is correct:
    [upgrade/config] Reading configuration from the cluster...
    [upgrade/config] FYI: You can look at this config file with 'kubectl -n kube-system get cm kubeadm-config -o yaml'
    [upgrade/config] FATAL: this version of kubeadm only supports deploying clusters with the control plane version >= 1.21.0. Current version: v1.20.11
    To see the stack trace of this error execute with --v=5 or higher

  • chrispokorni
    chrispokorni Posts: 1,218

    Hi @udayan.singh,

    What are the versions of your kubeadm, kubelet, and kubectl? The upgrade process supported is between consecutive minor versions, such as from 1.20 to 1.21, and/or from 1.21 to 1.22.

    The latest course release starts with version 1.21 and continues with an upgrade to 1.22.

    Regards,
    -Chris

  • zerodmg
    zerodmg Posts: 1

    Hey , here i have the same problem. i am using vms with ubuntu 20.04 (maybe that's the problem?).anyway there is a way to update the control plane or i have to start from scrach with other linux ? (if is the second, exactly what distribution/version , i need to use to avoid all problems?)

  • chrispokorni
    chrispokorni Posts: 1,218

    Hi @zerodmg,

    A different Ubuntu release alone, such as 20 in this case, may not be the reason why the upgrade process causes issues. If you take a closer look at Lab Exercise 3.1 you will discover that it is calling for Ubuntu 18.

    What may impact the upgrade process, however, are the following: cloud or hypervisor configuration, VPC/private network config, firewalls, VM config (CPU, MEM, disk, networking), whether kubeadm init was successful, etc.

    What step number and what error is returned when you attempt the upgrade exercise?

    Regards,
    -Chris

Categories

Upcoming Training