Welcome to the Linux Foundation Forum!

Exercise 13.3: Adding tools for monitoring and metrics - metrics-server.md missing reporitory

Tried to clone the repository and avter providing my credentials for github i get:
"
fatal: repository 'https://github.com/kubernetes-incubator/metrics-server.md/' not found
"
Also tried to go directly to the URL but recieved a 404.

Is the Repository down?

Answers

  • serewicz
    serewicz Posts: 994

    Hello,

    Step 1 of exercise 13.3 is to clone the repository. This git command just worked for me.

    Step 2 directs you to change into the new directory using cd and run less README.md, which has the "Installation" section and appropriate command and link to the YAML file. Also just worked for me

    As I have just tried these commands and they still work, what commands are you trying, and what errors are you seeing when you try steps 1 and 2?

    Regards,

  • lyzlisa
    lyzlisa Posts: 1

    The old url (https://github.com/kubernetes-incubator/metrics-server.git) of the metrics-server repository is still working but the course material can perhaps be updated to using the new url (https://github.com/kubernetes-sigs/metrics-server.git).

  • SevenD
    SevenD Posts: 3

    This command from Exercise 13.3 - Step 3:

    "kubectl create -f \
    https://github.com/kubernetes-sigs/metrics-server/releases/download/v0.3.7/components.yaml"
    

    now gives me this error message:

    unable to recognize "https://github.com/kubernetes-sigs/metrics-server/releases/download/v0.3.7/components.yaml": no matches for kind "APIService" in version "apiregistration.k8s.io/v1beta1"
    
    

    Simply following the lab exercises I am now at version:

    ient Version: version.Info{Major:"1", Minor:"23", GitVersion:"v1.23.1", GitCommit:"86ec240af8cbd1b60bcc4c03c20da9b98005b92e", GitTreeState:"clean", BuildDate:"2021-12-16T11:41:01Z", GoVersion:"go1.17.5", Compiler:"gc", Platform:"linux/amd64"}
    

    and the available API is

    $ kubectl api-versions 
    [...]
    apiregistration.k8s.io/v1
    

    So downloading the components.yaml file first and editing

    apiVersion: apiregistration.k8s.io/v1
    

    to match fixed the issue.

  • SevenD
    SevenD Posts: 3

    Even with that change to the components.yaml, I still got this error:

    1 webhook.go:196] Failed to make webhook authorizer request: the server could not find the requested resource
    

    double checking the README section again:

    Compatibility Matrix
    Metrics Server  Metrics API group/version   Supported Kubernetes version
    0.6.x   metrics.k8s.io/v1beta1  1.19+
    0.5.x   metrics.k8s.io/v1beta1  *1.8+
    0.4.x   metrics.k8s.io/v1beta1  *1.8+
    0.3.x   metrics.k8s.io/v1beta1  1.8-1.21
    

    I replaced 0.3.7 with 0.6.1

  • chrispokorni
    chrispokorni Posts: 1,508

    Hi @SevenD,

    The README.md also provides the installation command for the latest metrics-server release:

    https://github.com/kubernetes-sigs/metrics-server#installation

    Regards,
    -Chris

Categories

Upcoming Training