Welcome to the Linux Foundation Forum!

Exercise 3.5: Access from Outside the Cluster

Hello,
in this exercise I created in step 5 the "service again, but this time pass theLoadBalancertype. Check to see the status and note the external portsmentioned. The output will show theExternal-IPaspending. Unless a provider responds with a load balancer it willcontinue to show as pending".
In the step 6 I opened a browser on my local system and used the public IP of my master node and port32753, but the connection is refused and I am not able to see the Welcome Page of nginx server :(
Does anyone Know the reason?
Thanks for help

Alberto.

Comments

  • serewicz
    serewicz Posts: 994

    Hello,

    You created a LoadBalancer, and indeed the external IP shows - as the book mentioned. So far, so good.

    When you run kubectl get svc what is the port shown for the service? Is there a pod that the service is connecting you to. Remember a service is NOT a listener, just a pipe to deliver traffic somewhere. That somewhere needs to be working.

    Does the pod show the welcome page when you use the ephemeral IP, as found with kubectl get pod -o wide ?

    Did you disable any firewalls between you and the node? Are you testing from within the node or from your local machine to a different machine running the node?

    Regards,

  • albtau81
    albtau81 Posts: 11

    Hello,
    attached the snaphot of my terminal (putty connected to the master node).
    If I use the ephemeral IP of one worker node, I see the welcome page in html format, but if test from my local machine ( with an external browser) to an ephimeral IP of the pod or to the load balancer Cluster IP, the connection fails.

    Thx and regards,

    A.

  • serewicz
    serewicz Posts: 994

    Hello,

    If your ephemeral IP works, next try your internal service IP. That way we know the label and the selector are working. From the snapshot it would be 10.109.8.53. If that works, but your test from an external system fails I think it is a firewall issue.

    Regards,

  • chrispokorni
    chrispokorni Posts: 1,508

    Hi @albtau81,

    It seems you were trying to use the node port value 32753 from the lab guide. You are expected to use the node port value from your own cluster, which is displayed on step 5 by the kubectl get svc command. Please use the correct node port value to validate the access from the browser.

    Regards,
    -Chris

  • albtau81
    albtau81 Posts: 11

    Hi @serewicz ,
    I tested the internal service IP ( Load Balancer) and it works from within the remote node.Just if I test the connection to nginx server from my local machine, it goes in timeout with any browser ( I also disabled my enterprise firewall to check...).
    [email protected],
    yes i used the node port values 80:31974/TCP ( displayed by kubectl get svc command) but the connection goes in timeout..:(

    Regards,
    Alberto.

Categories

Upcoming Training