Welcome to the Linux Foundation Forum!

Lab 11.1 Linkerd check issues


When i run #linkerd check command I get following error pod/linkerd-controller-64f76c4bc4-qnnzf container public-api is not ready

When I checked the pods status in linked namespace most of the pods are in CrashLoopBackOff and Error state.

Am I doing something wrong?


  • aikina777
    aikina777 Posts: 2

    Following is events from inside failed pod

  • serewicz
    serewicz Posts: 1,000


    While the events inside the pod is a start, there are other places to look and try to find what the issue may be. Are any other pods in your cluster showing issues? When you look through describe, get, and logs output are there errors which may indicate the cause?

    What are you using to run the nodes, GCE, AWS, VirtualBox? How much resources do your nodes have, CPU and memory? Does top show you have enough resources?


  • emunger
    emunger Posts: 1

    I have the same error using GCE. TOP shows enough resources. No solution by now


Upcoming Training