Welcome to the Linux Foundation Forum!

transport: error while dialing: dial tcp connect: connection refused

alebaffa Posts: 3
edited June 12 in LFD272 Class Forum

Hi, I started the official course about Hyperledger Fabric Developer, but when I run ./network.sh up createChannel -ca -s couchdb I get the following error:

Error: failed to create deliver client for orderer: orderer client failed to connect to localhost:7050: failed to create new connection: connection error: desc = "transport: error while dialing: dial tcp connect: connection refused"
Channel creation failed

I am running it from Ubuntu 20.04 in WSL2 (Windows).
Did anybody already face this problem? Any idea how to fix it?

Thank you!


  • alebaffa
    alebaffa Posts: 3

    OK never mind I found the cause. The instructions say to run ./network.sh up createChannel -ca -s couchdb, but instead I tried to run first ./network.sh up and then ./network.sh createChannel -ca -s couchdb.

  • Bobbijn
    Bobbijn Posts: 78

    Hello @alebaffa, Great to see you were able to determine the issue, Keep Learning!

  • drcirculor
    drcirculor Posts: 2
    edited September 24

    Hi, I am getting the exact same error, but unfortunately it wasn't resolved by running the "up" and "createChannel" commands separately. If anyone has any ideas then please let me know.

  • Bobbijn
    Bobbijn Posts: 78

    Hello, Let's see if we can figure this out. This error usually occurs when one of the dependencies is out of sync. Please go back and check the versions of the dependencies, especially Docker. Let me know if this helps. Bobbi

  • drcirculor
    drcirculor Posts: 2
    edited September 28

    Thanks @Bobbijn

    Yes, you were right - I noticed this error when I brought up the network, "Local fabric binaries and docker images are out of sync."
    I ended up deleting the "fabric" and "fabric-samples" folders from "~/go/src/github.com/hyperledger", then repeating the curl and git steps in the "Hyperledger Fabric samples, binaries, and Docker images" section.
    The network startup and channel creation worked fine after that.

    Thanks for your help.


Upcoming Training