Welcome to the Linux Foundation Forum!

The connection to the server x.x.x.x:6443 was refused – did you specify the right host or port?

Options

Whenever I start my VMs(ubuntu master and worker running on Virtualbox) and run kubectl get nodes, this is the error I see
The connection to the server x.x.x.x:6443 was refused – did you specify the right host or port?

I tried re joining after kubeadm reset but I lose all my lab progress by doing so. Kindly suggest a fix for this.

Comments

  • devopsappsec
    Options

    I'd recommend checking to make sure your IPs in your VMs aren't changing. I was using vmware workstation and using NAT, and you can actually set a static ip for your lab nodes. I'm not sure what the process is for virtualbox, but I'm sure there is an equivalent.

    Something to check, anyway--might not be your issue.

  • chrispokorni
    chrispokorni Posts: 2,207
    Options

    Hi @skatakam,

    Aside form assigning static IP addresses to your vbox hosts, I'd also recommend that you modify the default IP subnet of vbox to prevent overlapping with the Pod IP network 192.168.0.0/16 managed by calico. Such an overlap will cause cluster DNS issues.

    Regards,
    -Chris

  • hemant1405
    Options

    I too keep getting below.. I have tried all solutions provided by google, but nothing worked. I am using aws ec2

    The connection to the server ...:6443 was refused - did you specify the right host or port?

  • chrispokorni
    Options

    Hi @hemant1405,

    It sounds to be a networking related issue, such as a firewall blocking access to a port.
    When provisioning the EC2 instances, did you happen to follow the set up video guide from the intro chapter? It provides step by step instructions on how to configure VM resources, and most importantly networking and firewalls.

    Regards,
    -Chris

  • serewicz
    serewicz Posts: 1,000
    Options

    Hello,

    Could you let us know what command you were running when you got the error? Were you on the control plane, or trying to access from a different system?

    I noticed someone mentioned kubeadm reset. This would cause the cluster to be destroyed. It does not destroy the .kube/config file. So after you built a new cluster you may have an issue with TLS keys causing a lack of access, even if the IP address is the same.

    Regards,

  • paristiz
    Options

    Hi, this has happened to me. In VM you must turn off swap: "sudo swapoff -a"

  • soramaru
    Options

    Hello,

    This is happening to me as well.
    I am also running an AWS EC2 instance, and I did follow all the steps in the setup guide.
    I get the message after running the following command.

    kubectl apply -f calico.yaml

    I have already ran swapoff -a, and I already checked the .yaml files for errors and could not find any.

  • alihasanahmedk
    alihasanahmedk Posts: 34
    edited January 2022
    Options

    Please perform the below steps on the master node. It works like charm.
    1. sudo -i
    2. swapoff -a
    3. remove the swap.img from root directory rm -rf /swap.img, if using swap partition exists.
    4. exit
    5. strace -eopenat kubectl version

    Then wait for a few minutes so that all the pods get in running states.

  • soramaru
    soramaru Posts: 17
    edited January 2022
    Options

    @alihasanahmedk said:
    Please perform the below steps on the master node. It works like charm.
    1. sudo -i
    2. swapoff -a
    3. remove the swap.img from root directory rm -rf /swap.img, if using swap partition exists.
    4. exit
    5. strace -eopenat kubectl version

    Then wait for a few minutes so that all the pods get in running states.

    @alihasanahmedk

    Thank you for your input.
    Unfortunately that did not work.
    I had seen something similar in my search for a solution.
    Most of the answers I run across center around SWAP, but I currently don't even have SWAP spaces set up my EC2 instance.

  • soramaru
    soramaru Posts: 17
    edited January 2022
    Options

    kubectl apply -f calico.yaml

    1. strace -eopenat kubectl version

    When I run both of the above commands, I still get the connection refused message, and they both yield and exit code of 1

  • alihasanahmedk
    Options

    No problem @soramaru . I can view your issue on call If you want to. Because that's works for me pretty much fine.

  • soramaru
    Options

    @alihasanahmedk

    That would be great. What is the best way, and time to get a hold of you ?

  • alihasanahmedk
    alihasanahmedk Posts: 34
    edited January 2022
    Options

    @soramaru mail me your free slots. I will let you know then.
    alihasanahmedkhan@gmail.com

  • soramaru
    Options

    @alihasanahmedk

    I am usually free from 1800-2200 on weekdays; however, I am currently located in Japan and operating on GMT +9 time zone. I can also be reached at caspar76@gmail.com

  • alihasanahmedk
    Options

    @soramaru
    I am located in Pakistan and Japan is 4 hours ahead of Pakistan. I will be available from 1900 to onwards PKT which will be 2300 JST time. Let me know you want to do this on weekends or on weekdays.

  • soramaru
    Options

    @alihasanahmedk
    I sent you a message to alihasanahmedkhan@gmail.com

  • alihasanahmedk
    Options

    @soramaru
    sure.

  • chrispokorni
    Options

    Hi @soramaru,

    Have you created a custom VPC with one SG to allow ingress traffic from all sources, all protocols, and to all ports?

    Also, if the cluster happened to be re-initialized, did you manage to copy again the /etc/kubernetes/admin.conf file to your $HOME/.kube directory as instructed by step 16 of Exercise 3.1?

    Regards,
    -Chris

  • soramaru
    Options

    @chrispokorni

    Your first suggestion may have been the cause to my problem.

    I ended up terminating my EC2 instance and starting a new one, and everything worked fine.

    I must have made a mistake when setting up my EC2 instance.

Categories

Upcoming Training