Welcome to the Linux Foundation Forum!

Labs 12.3 Cannot access metrics-server dashboard from browser

Options

Hi Linux Foundation team,

I've followed the lab successfully so far but could not fire up the browser to see the dashboard. I can successfully see the top pod / node metrics using kubectl inside my master node. I am definitely using the correct public IP address and high port number.

My setup is an EC2 instance running ubuntu. Is it possible to do with my secuirty group setting in aws? I made sure to allow inbound from both http and https (screenshots attached). Any tips on troubleshooting would be highly appreciated. Thanks!!!

Comments

  • serewicz
    serewicz Posts: 1,000
    Options

    Hello,

    Indeed it is probably your firewall. Please reference the lab guide which suggests opening up all of the ports. After that you could use the IP of the primary interface of the master node, the one inside the instance, not the public IP you use to get there. If you can see the dashboard using a tool like elinks, it would be another way to know it was the AWS firewall that blocks the traffic.

    Regards,

  • chrispokorni
    chrispokorni Posts: 2,221
    Options

    Hi @ValerieLi,

    Another possible issue is Chrome. As of late, Chrome no longer allows access to insecure websites. I would try accessing the dashboard through Firefox as an alternative to Chrome.

    Regards,
    -Chris

  • ValerieLi
    ValerieLi Posts: 4
    Options

    @serewicz @chrispokorni - good news. After i enabled all traffic from all ports it did work with the public iP exposed by AWS (in firefox browser). Hooray!

    While I have your attention, do you think i can trouble you with one similar issue? I happen to be also reviewing the last lab 16.2 today since it also requires you to access a HAProxy Stats dashboard and i'm getting 503 errors. My logs look fine and I'm attaching my config file. When I was researching online, it was suggested that it might be because my backend server is not available. Is there any way to test that? Some also suggest to change the default mode to http vs. tcp. It did not help resolve my issue. Btw I can successfully ping my master node from the loadbalancer node using the eth0 IP. Cheers!

  • chrispokorni
    chrispokorni Posts: 2,221
    edited June 2020
    Options

    Hi @ValerieLi ,

    Are you using the haproxy.cfg file provided in the SOLUTIONS tarball? And you only modified the IP address and the name of your Master-1 in that file? And your haproxy.service restarted without any issues? And you tried the full path as it is presented in the lab exercise http://3.22.164.15:9999/stats ?

    That is very strange, because I just accessed your haproxy dashboard :smile: Unless you were able to fix it in the meantime, I can't see anything wrong with it.

    Regards,
    -Chris

  • ValerieLi
    ValerieLi Posts: 4
    Options

    Whoaa, i'm super amazed and puzzled because I didn't do anything since last night and yes I can access it without problems now... thanks so much again @chrispokorni!!!!

  • chrispokorni
    chrispokorni Posts: 2,221
    Options

    Then it could have been the missing /stats from the URL, based on your screenshot.

  • ValerieLi
    ValerieLi Posts: 4
    Options

    Happy to report I took the CKA exam last week and got a passing score! Thanks so much for all the help! @chrispokorni @serewicz

  • serewicz
    serewicz Posts: 1,000
    Options

    Congrats!!!

  • chrispokorni
    chrispokorni Posts: 2,221
    Options

    Congratulations @ValerieLi!
    Welcome to the family ;)

Categories

Upcoming Training