Welcome to the Linux Foundation Forum!

Lab 10.1 Ingress kubernetes 1.18

I'm using a Kubernetes 1.18 to exercise the labs. When I need to create the resource ingress.rule.yaml the API gives me an error because the 'apiVersion: networking.k8s.io/v1' does not exist. To correct I have to modify the yaml to use 'apiVersion: extensions/v1beta1'.

Comments

  • fcioanca
    fcioanca Posts: 1,280

    The course is based on Kubernetes v1.17.1. It has not been updated to v1.18 yet.

  • Of course, it's just a hint for someone that needs to execute the exercises in the new version of kubernetes. But it's curious that in version 1.17 the networking.k8s.io/vi becomes stable and in 1.18 get back to extensions/v1beta1.

  • dnx
    dnx Posts: 30

    I'm on 1.17 and have to make the same change to the apiVersion.

  • dnx
    dnx Posts: 30

    I'm on 1.17 and have to make the same change to the apiVersion.
    $ kubectl version Client Version: version.Info{Major:"1", Minor:"17", GitVersion:"v1.17.1", GitCommit:"d224476cd0730baca2b6e357d144171ed74192d6", GitTreeState:"clean", BuildDate:"2020-01-14T21:04:32Z", GoVersion:"go1.13.5", Compiler:"gc", Platform:"linux/amd64"} Server Version: version.Info{Major:"1", Minor:"17", GitVersion:"v1.17.1", GitCommit:"d224476cd0730baca2b6e357d144171ed74192d6", GitTreeState:"clean", BuildDate:"2020-01-14T20:56:50Z", GoVersion:"go1.13.5", Compiler:"gc", Platform:"linux/amd64"}

  • crumdev
    crumdev Posts: 10

    I had the same issue on v1.17 as well although the documentation has updated mid training and now has v1beta1 in the example and everything is v1.18 after I have setup a v1.17 instance of everything.

  • serewicz
    serewicz Posts: 994

    Hello,

    Yes, the Kubernetes version in use by the course has updated to 1.18.1, in order to keep pace with the exam which is expected to update any day. Kubernetes releases on a three month schedule. Constant change and updates should be expected. Using the updated file in the new tarball the lab should work. As you look at the preceding messages it is a matter of which API version was declared in the YAML file.

Categories

Upcoming Training