Welcome to the new Linux Foundation Forum!

Unable to setup cluster on Lab 3.1

As I'm following the instructions in the book, the setup for kubeadm init --config=kubeadm-config.yaml --upload-certs --v=5 | tee kubeadm-init.out fails with API Server not being available.

On running systemctl status kubelet the output is

and on running journalctl -xeu kubelet the output is

I've tried debugging by using other forums online but to no use. If I try to figure out the logs for the containers, the output is

Please help!

Comments

  • serewiczserewicz Posts: 553

    Hello,

    I see a lot of errors saying "pranaynada2c.mylabserver.com not found". If you edited /etc/hosts and the kubeadm-config.yaml files properly, and only used k8smaster as the server name, kubelet shouldn't be asking for the actual host name.

    1. I would first make sure you are not changing the hostname, just adding an alias to your primary IP to /etc/hosts.
    2. Double check the name and other values in kubeadm-config.yaml
    3. Ensure you are using a fresh instance, not one that failed,edited and tried again. Not everything is cleaned out by kubeadm reset
    4. Test that the alias works using ping prior to running kubeadm init on the fresh system. Double check you are using your primary interface.

    Regards,

Sign In or Register to comment.