Welcome to the Linux Foundation Forum!

Help with Lab 3, Steps 4 and 5


I do apologize for the lack of knowledge on topics I should have, but I have been tasked with figuring this stuff out and some aspects of Linux I am not strong in.

I ran step 4:
root@lfs458-node-1a0a:~# vim /etc/apt/sources.list.d/kubernetes.list
deb http://apt.kubernetes.io/ kubernetes-xenial main

The file was empty\new, so I added that one line and saved the file. It is really there.

Step 5 fails: gpg: no valid OPenGPG data found. The command I ran is:
curl -s \ https://packages.cloud.google.com/apt/doc/apt-key.gpg \ | apt-key add -

Sorry I know nothing else as to why, any suggestions. I would suggest to assume nothing in what I have done. I am following hte course letter for letter.

Thank you


  • prenticect
    prenticect Posts: 21

    FYI, it worked... It was my bad as I typed it all on one line and the instructions did say to enter different lines. When I did that it worked

  • serewicz
    serewicz Posts: 1,000

    Yes, the backslash is to indicate line continuation. So you would not type them in when using a single line. If you hit "Enter" right after typing the backslash you would get a line continuation. It is a way of causing a new line without the parsing.


Upcoming Training