Welcome to the Linux Foundation Forum!

Can not remove node.kubernetes.io/not-ready:NoSchedule taint

oliveriomoliveriom Posts: 5
edited December 2018 in LFD259 Class Forum

In Chapter 2 .1 Labs/Exercise 2.1: Deploy a New Cluster I am trying to remove the node.kubernetes.io/not-ready:NoSchedule taint but no success.

I ran the kubectl taint nodes --all node.kubernetes.io/not-ready- many times and get

node/kubemaster untainted
node/kubeworker untainted

as the output. But then when I run kubectl describe nodes |grep -i Taint I get

Taints:             node.kubernetes.io/not-ready:NoSchedule
Taints:             node.kubernetes.io/not-ready:NoSchedule

and kubectl get nodes returns NotReady:

kubemaster   NotReady   master   78m   v1.12.1
kubeworker   NotReady   <none>   76m   v1.12.1


  • Resetting it with sudo kubadm reset and re-running the whole config fixed it.

  • serewiczserewicz Posts: 663

    Thank you for the update.

    There seems to be a bit of a feature that it takes about a minute between attempts for the taint to be fully removed. I believe in the notes it mentions this feature in the 1.12.x versions.


  • @oliveriom
    A few times I ran into similar behavior, but most times the taint removal worked as expected. When it did not, a reset and reconfiguration worked without any issues.

Sign In or Register to comment.