Welcome to the new Linux Foundation Forum!

Calico plugin not working with 1.12 kubernetes. Please, update the k8sMaster.sh

Hi,

I am using the k8sMaster.sh to setup the kubernetes.

Whenever I apply the calico.yaml file the networking plugin is not getting applied with the following error:

Oct 28 19:47:23 abhi-VirtualBox kubelet[7509]: W1028 19:47:23.770295 7509 cni.go:188] Unable to update cni config: No networks found in /etc/cni/net.d
Oct 28 19:47:23 abhi-VirtualBox kubelet[7509]: E1028 19:47:23.771205 7509 kubelet.go:2167] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized
Oct 28 19:47:28 abhi-VirtualBox kubelet[7509]: W1028 19:47:28.773128 7509 cni.go:188] Unable to update cni config: No networks found in /etc/cni/net.d
Oct 28 19:47:28 abhi-VirtualBox kubelet[7509]: E1028 19:47:28.773271 7509 kubelet.go:2167] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized
Oct 28 19:47:31 abhi-VirtualBox kubelet[7509]: E1028 19:47:31.628914 7509 pod_workers.go:186] Error syncing pod a03c1c56-db21-11e8-8b4c-080027cdb0b0 ("coredns-576cbf47c7-2rlws_kube-system(a03c1c56-db21-11e8-8b4c-080027cdb0b0)"), skipping: network is not ready: [r
Oct 28 19:47:33 abhi-VirtualBox kubelet[7509]: W1028 19:47:33.774176 7509 cni.go:188] Unable to update cni config: No networks found in /etc/cni/net.d
Oct 28 19:47:33 abhi-VirtualBox kubelet[7509]: E1028 19:47:33.775051 7509 kubelet.go:2167] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized
Oct 28 19:47:38 abhi-VirtualBox kubelet[7509]: W1028 19:47:38.779404 7509 cni.go:188] Unable to update cni config: No networks found in /etc/cni/net.d
Oct 28 19:47:38 abhi-VirtualBox kubelet[7509]: E1028 19:47:38.779590 7509 kubelet.go:2167] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized
Oct 28 19:47:42 abhi-VirtualBox kubelet[7509]: E1028 19:47:42.623030 7509 pod_workers.go:186] Error syncing pod a03c1c56-db21-11e8-8b4c-080027cdb0b0 ("coredns-576cbf47c7-2rlws_kube-system(a03c1c56-db21-11e8-8b4c-080027cdb0b0)"), skipping: network is not ready: [r
Oct 28 19:47:43 abhi-VirtualBox kubelet[7509]: W1028 19:47:43.780887 7509 cni.go:188] Unable to update cni config: No networks found in /etc/cni/net.d
Oct 28 19:47:43 abhi-VirtualBox kubelet[7509]: E1028 19:47:43.781509 7509 kubelet.go:2167] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized
Oct 28 19:47:48 abhi-VirtualBox kubelet[7509]: W1028 19:47:48.783071 7509 cni.go:188] Unable to update cni config: No networks found in /etc/cni/net.d
Oct 28 19:47:48 abhi-VirtualBox kubelet[7509]: E1028 19:47:48.784031 7509 kubelet.go:2167] Container runtime network not ready: NetworkReady=false reason:NetworkPluginNotReady message:docker: network plugin is not ready: cni config uninitialized

Comments

  • Ok, got it working. I had not seen the latest document. Thanks

  • rymonroerymonroe Posts: 2

    @abhijitherekar I'm currently troubleshooting same issue. How did you get it to work?

  • ****As of v1.12.1 with the early October version of Calico new nodes now have another taint,
    node.kubernetes.io/not-ready:NoSchedule. We need to remove this taint so that the scheduler will begin to allocate
    Calico pods to both nodes. They need to be running prior to nodes showing Ready. As of this writing the taint
    removal may take two or three times to work. Wait a minute, view taints and run the command again until the taints
    are removed.****

    [email protected]:~$ kubectl describe nodes |grep -i taint
    Taints: node.kubernetes.io/not-ready:NoSchedule
    Taints: node.kubernetes.io/not-ready:NoSchedule

    [email protected]:~$ kubectl taint nodes --all node.kubernetes.io/not-readynode/ckad-1
    untainted
    node/ckad-2 untainted

    [email protected]:~$ kubectl describe nodes |grep -i Taint
    Taints: node.kubernetes.io/not-ready:NoSchedule
    Taints:

    [email protected]:~$ sleep 60 ; \
    kubectl taint nodes --all node.kubernetes.io/not-readynode/ckad-1
    untainted
    taint "node.kubernetes.io/not-ready:" not found

    1. Check that both nodes are without a Taint. If they both are without taint the nodes should now show as Ready. It may
      take a minute or two for all pods to enter Ready state.

    [email protected]:~$ kubectl describe nodes |grep -i taint
    Taints:
    Taints:

    [email protected]:~$ kubectl get nodes
    NAME STATUS ROLES AGE VERSION
    LFD259: V 2018-10-21 c Copyright the Linux Foundation 2018. All rights reserved.
    2.1. LABS 7
    ckad-1 Ready master 6m1s v1.12.1
    ckad-2 Ready 5m31s v1.12.1

  • @rymonroe Please check my comment.

  • @rymonroe Please check my comment.

  • serewiczserewicz Posts: 419

    @rymonroe Were you able to get it working?

  • rymonroerymonroe Posts: 2

    After removing taints everything worked. Thanks!

Sign In or Register to comment.