Welcome to the Linux Foundation Forum!

Lab documentation for setting up devstack appears to be wrong?

In the first lab where you're supposed to setup devstack, it says to use eth2 and the eth2 IP for the host IP. Except there is no eth2 on my devstack node. There is only ens3 which appears to be a public IP and virbr0 which is a private IP but appears to not be connected to a physical network.

I tried using the virbr0 IP to setup devstack which worked, but now I'm trying to setup the second compute node and virbr0 on that node is also Both labs say to use the 192.168.x.x address to set up the nodes but the address is the same on both hosts. Am I supposed to be using the ens3 public ip address for both nodes instead? I tried this on the compute node but it failed to add the second hypervisor and I can only assume it's because it's trying to contact the first node on the public IP but that node isn't listening on that IP.

So something is out of sync with the instructions and the lab and I'm not really sure how to proceed at this point, I'm stuck on 3.5 because I can't get the second compute node added and when I get to the spot to manually add it by running discover hosts, it just gives me a huge python traceback ending in an SQL error.


  • Hello,

    Are you finding the error in Exercise 3.2: Add a Compute Host, step 7? You mention 3.5, but that's not what I'm finding. When I look at the interfaces I see an ens3 interface on the node which matches what the lab mentions. Please could you provide more information about where you are seeing the references to eth2.


  • Thanks, I actually continued with my modified settings and it seemed to work, but that was awhile ago now so I don't remember exactly what I changed.

  • Okay, let us know if it happens again and we can try to troubleshoot the issue.



Upcoming Training