Welcome to the Linux Foundation Forum!

Lab 3.1

fargozhu Posts: 1
edited June 2018 in LFS258 Class Forum

Lab 3.1 step 3

root@k8s-lab31:~# apt-get install -y docker.io

Reading package lists... Done

Building dependency tree

Reading state information... Done

Package docker.io is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, oris only available from another source

E: Package 'docker.io' has no installation candidate



  • chrispokorni
    chrispokorni Posts: 2,208
    edited June 2018


    Would you mind providing a few details about your setup to help in identifying the cause of your error? What distribution are you running? Are you on GCE, EC2, Azure vm, Virtual box, VMware,... ? What networking policy/firewall you have setup? 

    My setup on GCE, 2 vCPU instances, Ubuntu 16.04 LTS and 18.04 LTS produce a similar error only if I run the docker install command without an apt-get update before.

    To find if docker.io is available to install for your distribution you can try 

    apt-cache pkgnames


    apt-cache search

    Depending on the distribution, a different docker installation approach may be required, based on their official documentation.



  • serewicz
    serewicz Posts: 1,000


    I've seen this error when using Suse, and had to enable a particular backport to get it to work. Could you verify which version of Ubuntu you are using?



  • viralsanghavi7

    I came across the same error. I am still working on to resolve. But meanwhile, you can install Docker through the Linux distros installation script. Quite an easy and straightforward

    curl -sSL https://get.docker.com/ | sh

    More info here: https://github.com/docker/docker-install

  • serewicz
    serewicz Posts: 1,000

    In order that you have the least amount of issues, I would encourage you to use the suggested version and OS. Of course once you have the labs down, trying to get them to work in other places is encouraged.



Upcoming Training