Welcome to the Linux Foundation Forum!

LAB 8.1 centos-release-openstack-newton package not found???

qxr2883qxr2883 Posts: 3

When trying the yum install -y centos-release-openstack-newton.


  • edited May 2018

    yup, me too.

    I have found: yum install https://repos.fedorapeople.org/repos/openstack/openstack-newton/rdo-release-newton-5.noarch.rpm

    But It is not a solution, as centos mirror do not have newton in it's repos.

    I have done: yum erase rdo-release-newton-5.noarch.rpm

    yum install https://rdo.fedorapeople.org/rdo-release.rpm

    yum install centos-release-openstack-queens.x86_64

    Then had issues with Install so I did as yum suggested:

    yum install  --disablerepo=centos-qemu-ev -y openstack-packstack vim && yum update --disablerepo=centos-qemu-ev -y


    Also I would add, that in chapter 8 I think some audio do not match slides especially where is neutron-l3 and other agent config, I think it was 8.8.b or smth


  • serewiczserewicz Posts: 667
    edited May 2018


    Thank you for letting us know. I am in the process of updating the labs to Pike and hope to be able to publish the detailed steps soon. To use Pike, in the basic sense, would be to use this instead to get the software started: 

    sudo yum install -y centos-release-openstack-pike

    There will be some minor differences in the other RDO labs, which I am in the process of figuring out and will publish as soon as possible.


  • prempython2018prempython2018 Posts: 6
    edited June 2018

    Serewicz, have you updated the labs to use Pike as you said and if you have done it then pls share the details on how install RDO because the instruction we have under Lab8.1 is still accoridng to newton release and its not going through after trying with pike 

  • and getting error as below and inside the log also, same error message are logged

    Applying                       [ ERROR ]

    Applying Puppet manifests                         [ ERROR ]

    ERROR : Error appeared during Puppet run:

    Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-cinder' returned 1: Transaction check error:

    You will find full trace in log /var/tmp/packstack/20180626-235214-kzRm_n/manifests/

    above error are coming when I used Queens release and installing rdo through packstack

  • serewiczserewicz Posts: 667
    edited June 2018


    I have completed the lab updates to run Pike for both DevStack and RDO. I've also updated Ceph and other products to be up to date.  At the moment we are in the middle of moving the lab environment to a new provider.  I hope to report all is well soon, but I do no have access to their back end. I regularly communicate with them and hope for success soon.



  • serewicz, thanks for your quick response and I will be waiting for your confirmation.

  • Serewicz , Do we have any update for your lab setup and documents update completion for Pike version ?

  • serewiczserewicz Posts: 667


    I've been able to work with the new team to get about half of the labs working on the new environment.  Sadly I have no access to the back-end and can only provide the steps and help troubleshoot issues as their found. It is being worked on, but I cannot provide a more concrete date. I'm doing my best to move each step along.



  • Thanks for your response and if you can provide the steps, will be great and I can try it with you steps.

  • ces2601ces2601 Posts: 6
    edited July 2018

    hi, as of today, i still see the lab with newton releaese, i'm using the workaround:

    yum install -y centos-release-openstack-pike
  • ces2601ces2601 Posts: 6
    edited July 2018

    hi, as of today, i still see the lab 8 has newton release on the instructions, im using the workaround

    yum install -y centos-release-openstack-pike
  • otma2000otma2000 Posts: 3

    just related comment to using the pike version.

    [[email protected] ~]# sudo yum install -y centos-release-openstack-pike

    Loaded plugins: fastestmirror, langpacks

    base                                                                                                                               | 3.6 kB  00:00:00

    centos-ceph-jewel                                                                                                                  | 2.9 kB  00:00:00

    centos-openstack-pike                                                                                                              | 2.9 kB  00:00:00

    http://mirror.centos.org/$contentdir/7/virt/x86_64/kvm-common/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

    Trying other mirror.

    To address this issue please refer to the below knowledge base article


    If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/

  • Hello Serewicz, I just bought the openstack training and I am having the issue described here. Material is still not updated. Do you have the updated material using spike?



  • serewiczserewicz Posts: 667
    edited August 2018


    Following are some steps to get your environment for lab 8 up and running. I've been using this to test the being-built lab environment. Hopefully it helps until the new environment becomes availabe.



    yum install -y centos-release-openstack-pike yum install -y openstack-packstack vim packstack --gen-answer-file rdo.txt #Edit the file and change the following four variables, among the many vim rdo.txt CONFIG_HEAT_INSTALL=y CONFIG_NTP_SERVERS=0.pool.ntp.org CONFIG_DEBUG_MODE=y CONFIG_KEYSTONE_ADMIN_PW=openstack #Allow root/packstack to SSH locally vim /etc/ssh/sshd_config PermitRootLogin yes PasswordAuthentication yes systemctl restart sshd packstack --answer-file rdo.txt #Configure web server to allow calls to public IP address vim /etc/httpd/conf.d/15-horizon_vhost.conf ServerAlias 104.130.xx.yy #Put your PUBLIC IP here systemctl restart httpd ; systemctl restart memcached


Sign In or Register to comment.