Welcome to the new Linux Foundation Forum!

Issues with lab 3.3 (open stack is not found)

ces2601ces2601 Posts: 6



I'm having issues with lab 3.3, following the guide the first issue i have is "openstack" is not installed:


[email protected]:~$ cd ~/devstack/
[email protected]:~/devstack$ source openrc admin
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
[email protected]:~/devstack$ openstack
The program 'openstack' can be found in the following packages:
* python-openstackclient
* python3-openstackclient
Try: sudo apt install <selected package>

 

After installing "python-openstackclient" I was able to start the openstack utility, but failed to create the project.


[email protected]:~/devstack$ openstack
(openstack) project create CallCenter
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Could not determine a suitable URL for the plugin
(openstack)

 

I'm not sure how to proceed.

Comments

  • serewiczserewicz Posts: 575
    edited April 2018

    Hello,

    Thank you for letting us know about this issue. It seems with Pip moved to version 10 it has caused some errors. Instead of a check script looking at the values the script was doing a string comparison, so version 10 was interperated as 1, which would be less than the minimum version 6. Its' a bug. The fix is to edit line 336 of /home/ubuntu/devstack/inc/python and change one word from strip to split: 

    which is to edit /home/   line 336 from:         

                         print(pip.__version__.strip('.')[0])")

    to

                          print(pip.__version__.split('.')[0])")

    Here is the bug:

    https://bugs.launchpad.net/devstack/+bug/1764046

    Here is the fix in detail:

    https://review.openstack.org/#/c/561411/3/inc/python

    This seems to be causing a secondary issue with the version of psutils, which is not installed via pip, but instead via a system utility. https://bugs.launchpad.net/devstack/+bug/1763966

    It would seem that as it was installed outside of OpenStack, the ./stack.sh script is unwilling to update the software. 

    The fix seems to be removing the apt package and installing the newer pip package. 

    sudo apt-get remove python-psutil

    sudo pip install psutil

    I did a ./unstack.sh, ./clean.sh. Then removed the apt package and installed the pip version of psutils. When those finished I ran the ./stack.sh script again and it seems to have worked.

    I have let the infrastrucure team know about the issue, i'm sure they will implement the fix soon. It may take a bit to test and roll out the fix. 

    Regards,

     

Sign In or Register to comment.