Welcome to the Linux Foundation Forum!

No internet and unable to mount CD on Arch Linux inside VirtualBox

Hello to all who read!

Hopefully, I'm posting this in the right forum.

I'm new to Arch Linux and I just installed it, but I want to give it a try.

For some reason, I can't connect to the internet (I guess missing drivers), and then when I try to install Vbox guest additions, I can't mount the CD.

Any thoughts?

Thanks to all posts!

Comments

  • mfillpotmfillpot Posts: 2,180
    Have you tried to mount the cd image using the mount command?
  • Yep, I tried "mount /dev/sr0 /mnt/cd" and I get a message saying "Invalid device"
  • Ok, I found a way to install additions, but device "eth0" is still not found by "ifconfig"
  • mfillpotmfillpot Posts: 2,180
    it is good to see that you got the additions installed.

    Have you confirmed that have a valid netork adapter set for the virtual machine and that the mode can talk to your router?
    Also, have you tried running "ifconfig -a" to see all of your available adapter to confirm if the adapter is even seen?
  • The adapter is being seen, but still no connection
  • mfillpotmfillpot Posts: 2,180
    It sounds like the virtual machine is unable to obtain a dhcp lease address, which is most likely due to the wron network type configured for the virtual machine.

    Can you tell me network type is used the the adapter in the Vmware client configuration?

    using the bridged adapter type the virtual machine acts as though it is another computer connected to you local network, so it will request a dhcp address from the router.
  • Sorry for the delay, but I have already resolved this issue (I ran "dhcpcd")
    Thanks anyway for the help!
  • Hi Folks Sorry to intrude on you discusion. I have tried to start a new one but for some reason cannot type in the boxes from the new topic box.
    Please point me the right direction to get the following solved.
    My question is:
    I have a customer who has a red hat epos application running on a 6 year old PC that the HD is dying. He has a backup on to zip drive disk that I can read but the data, all his products plus sales over 6 years, is in a file called FILESAVE, no extension. I am urgently needing to open this and convert to csv or other Windows format (sorry for the rude word ‘Windows’) for now. The applications supplier has ceased trading due to the death of the programmer. The file concerned is available via the mailbigfile link http://mbf.cc/cXN3m. The firm I sent this to have not even had the decency to acknowledge my messages.
    Can you pass this on to the appropriate person/forum please. It is very urgent as the shop concerned is very busy for the Xmas trade.
    Looking forward to hearing from you soon. If Email please use the [email protected] account as that will go to mobile smart phone
  • mfillpotmfillpot Posts: 2,180
    Tillman,
    The file you have saved is actually a tar.gz compressed archive just like a zip file. If you add the extension .tar.gz to the end of the filename you will be able to open it with winzip, p7zip or tar.

    However after extracting the archive I did not see any actual customer data, it just appears to be the application files and libraries and the demo files.

    I was able to figure out the file type by using the "file" application in Linux.

    Hopefully you can share this information with the appropriate people who can guide you to the actual data files.
Sign In or Register to comment.