Welcome to the new Linux Foundation Forum!

Driver for Broadcom not activating! Help!

I just installed Ubuntu 10.04 on my HP Pavillion Laptop. So far, everything is going great, except that I am unable to access my wireless network via my wireless card. Whenever the Hardware Drivers notifies me that my wireless card needs activated, I get this error message:

Failed to fetch cdrom:[Ubuntu 10.04 LTS _Lucid Lynx_ - Release i386 (20100429)]/pool/main/p/patch/patch_2.6-2ubuntu1_i386.deb File not found

I have a Broadcom STA wireless driver.

What do I do to activate the driver? Is there a patch or download available? Will I need to use code? If so, how do I do that? I am still new at this and am eager for my wireless to work. Any help is appreciated!

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    Installing the driver should be enough, I don't understand it needing to be activated, unless it's some kind of a broadband 3g card, which I'm guessing it isn't. Can you go to terminal and let us know the output of lspci?

    Try:
    lspci | grep -i wire or
    lspci | grep -i wifi

    and see if you get a response from either of those, if not just past the result of lspci.
    Since it's Ubuntu, I'm not sure if you need raised permissions to execute those commands. If you get an error precede the command with sudo, i.e.,

    sudo lspci | grep -i wire.

    Any questions, post back.
  • mfillpotmfillpot Posts: 2,180
    It looks like the program was attempting to pull the driver file from your cdrom, I recommend putting the cdrom into the computer and updating your sources list prior to trying to activate the driver.
  • Put the CDROM in, hoping that would get me somewhere...guess not. Sources told me I need a working connection to the internet, so I'm gonna try a wired connection to the internet and see if I can get it there. Thanks!
  • Tried both, and the only response I got was from lspci grep -i wire

    02:05.0 FireWire (IEEE 1394) : Richo Co Ltd r5c832 IEEE 1394 Controller (rev 05)

    I went to the help menu last night and tried the Help 5.2 Troubleshooting a Wireless connection. Tried

    sudo lshw -c network

    result was disabled, and suggested I turn my wireless on. I tried it with the switch in both positions and it was disabled either way. Going to hard wire to the internet and see what I can come up with.

    Thanks!
  • Update: Tried downloading directly from a wired eth0 connection--the port did not recognize the internet connection. Called the tech support for the internet, said that there was something up with the port on my end (duh) and suggested I download the driver onto a thumbdrive then put on my laptop. So I did. Now, I don't know how to upload it from my thumbdrive to ubuntu. Tried the package manager--said I needed a CDROM--tried the CDROM, keeps saying to insert the disc (which, might I add, inserted.)

    So I checked the readme.txt file that came with the downloaded driver for broadcom 4311, and it said that I needed to uninstall or blacklist all other drivers before attempting to reinstall. How do I do this? I entered the commands from the readme into terminal and it didn't do anything--no response, nothing.

    What am I doing wrong?
  • Goineasy9Goineasy9 Posts: 1,116
    When you plug in a usb thumbdrive, Ubuntu should recognize it and bring up a folder showing what it contains. I usually just bring up another copy of the file manager and drag and drop the file from the usb stick into your home directory. At that point right clicking on the file and choosing open or install might work.
    But, you are having problems so I'm not assuming anything at the moment.
    Does plugging in the thumbdrive to the usb port bring up a folder window?
    Can you find Nautilus (file manager) in the menu system?

    If the answer to the last 2 lines is yes, let me know, and we'll continue.
  • Thumbdrive works, and found nautilus, but it won't let me open it...I guess I don't have the viewer.

    Opened the file browser and tried to drag and drop it into the home directory, but now its saying it cannot be copied because I don't have permissions to create it in the destination (/-file browser).

    Obtained another patch (http://ubuntu/pool/main/p/patch/patch_2.6-2ubuntu1_i386.deb) that it said it needed for the broadcom, but I can't get this one to install, either.

    Seems like the big problem now is permissions and authorization. What is up with that?
  • mfillpotmfillpot Posts: 2,180
    You must make sure that your user is in the plugdev group, this can be checked and correct by going into System > Administration > Users and Groups, selecting your user and choosing the groups tab to specify the groups you should belong to.
  • Goineasy9Goineasy9 Posts: 1,116
    The broadcom-wl driver is something that does not require a patch in order to get it to work. Loading the drivers is all it takes. If you can't find the card/chipset when executing "lspci", then your card is not working, or is switched off in your laptop. If you flip the switch and still don't see it in "lspci", then either the switch or the card is defective.
    BTW - How do you know the chip in your laptop is a broadcom 4311? I read the thread again, and can't find that info. I would still like to see the output of lspci.
Sign In or Register to comment.