Welcome to the new Linux Foundation Forum!

Need help removing nvidia driver

Today I decided to install a nvidia driver for my 32-bit fedora 11 machine, graphics card (fx5200). Everything went well until I rebooted and found out I installed the wrong driver. I tried to install the correct driver using yum but that conflicted with the existing driver installed. Is there a simple way just to revert to the nouveau driver?

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    Actually it's not that simple, but is pretty easy. Question is, how did you install the drivers to start out with. If you installed them from the nVidia site, reverting back to nouveau is a bit harder than if you installed them from the rpmfusion repo. So, ... how did you install the drivers.
  • I ran "yum install kmod-nvidia", I don't know if that accesses the rpmfusion repo. I'm still learning linux.
  • Goineasy9Goineasy9 Posts: 1,116
    Hi, well, if you do in a terminal:

    su -c "yum remove kmod-nvidia"

    that's a start. Installing that driver also blacklisted nouveau so you have to:

    su -c "rm /etc/modprobe.d/blacklist-nouveau.conf"

    then,

    su -c "rm /etc/X11/xorg*"

    to remove the xorg.conf file and other remnants of the nvidia setup.

    Then all you have to do as reboot and you should be back into nouveau.

    You can copy and paste those lines into your terminal, but if you decide to just type them out, just make sure that X11 is a capital "X", everybody makes that mistake.

    BTW - if you decide to reinstall nVidia drivers, ask and we'll tell you the steps you need to do it successfully. It takes more than just installing kmod-nvidia, because Fedora ties it's kernel so close to the nouveau drivers.

    Any questions, just post back, especially if your uncertain about anything. Also, you should type and execute all commands before rebooting, or else you'll get a black screen.
  • Ok thanks for all of the help! I should have also mentioned due to the incorrect driver installed the GUI on Fedora fails to load.
  • Well I tried what you suggested but it still failed to load up the GUI. I should have also mentioned that yum installed a kernel version when as a dependency for the nvidia driver. Just when the GUI would normally load the screen flickers rapidly for about 10 seconds and it gets stuck on jexec services.
  • Goineasy9Goineasy9 Posts: 1,116
    OK, well, when I first used Fedora I made the same mistake. The default installation loaded a PAE kernel instead of the regular kernel. So when I installed kmod-nvidia it also pulled in a regular kernel. For your install you probably would have had to load up kmod-nvidia-PAE. What you will have to do to clean up the installation is remove the kernel that came in with the kmod-nvidia driver and reset everything using the old kernel. OR. If it is a new installation, just do a reinstall. The choice is up to you. Since I made the same mistake, I can help you fix it. If this is what you want to do, let me know if you see the grub screen when you are booting up, so we can stop the boot from going into gnome and go directly into terminal.
    We can also use the live cd to do the repair. But if you can stop the boot at grub, it might be easier because we can just boot into init 3 (by adding 3 to the kernel line) and work from there.
    A default Fedora install sets grub to a timeout of zero so that's why I'm asking if you can see it while booting up.
  • I would like to reset everything using the old kernel. I do not see the grub screen when it boots up.
  • mfillpotmfillpot Posts: 2,180
    I am moving this thread to the fedora section because it has to do more with fedora's package management functions than drivers themself.
  • Goineasy9Goineasy9 Posts: 1,116
    Thanks mfillpot, it really does belong in Fedora.

    @win2tank Fedora, as I said before, sets the timer on grub to zero, so, it's hard to catch. Experiment by hitting escape occasionally while it is booting up and see if you can catch grub. If you hit it at the right spot, we can work on it from there. Since we are going back and forth on the forum, I'll try and tell you some things in advance, in case we don't catch each other here at the same time.

    If escape works and you can catch grub, press "e" when it appears and add a "3" (without quotes) to the kernel line so we can boot up into init 3, which will leave you at a terminal screen with a prompt.
    If you can't catch grub with escape, you will need a LiveCD of Fedora, or, actually almost any other Linux distro. Let me know what you have and we'll go from there.

    I'm first trying to get a copy of your grub.conf so I can see what kernels are installed and at the same time I'll help you fix grub so it shows up during boot.

    If escape does work and you get to a prompt type in:
    su -c "cat /boot/grub/grub.conf"
    

    I need the output from that command to get us started.

    I'll leave it at that for now, let me know how you make out.
  • I took a picture of the output I got from cat /boot/grub/grub.conf. Sorry for the small image, the site would not let me load a much larger file size. 2010_01300001.JPG
  • Goineasy9Goineasy9 Posts: 1,116
    Good news, you didn't install the wrong type of kernel, you just installed a newer kernel. Nothing to do here, but, lets make sure you can see grub the next time you boot up.

    su -c "nano /boot/grub/grub.conf" will open up that file for you.

    Change timeout=0 to timeout=3 , and
    put a hash mark in from of hiddenmenu (make it #hiddenmenu)

    Then hitting ctrl-x and then "y" will save the file for you.

    You should be back to a prompt at this point, so lets see what you have.

    Let me see the output of
    dir /etc/modprobe.d/
    and
    dir /etc/X11/
  • Ok great. Here is the output: 2010_01300003.JPG
  • Goineasy9Goineasy9 Posts: 1,116
    ok, you still have an xorg.conf that didn't get removed.

    su -c "yum remove /etc/X11/xorg*"

    Don't forget the asterisk after xorg, it helps remove the xorg.conf and it's backup file.

    You can try rebooting after that. Keep your fingers crossed.
  • I tried that command if it found both file but I got something like no argument associated with both files.
  • Goineasy9Goineasy9 Posts: 1,116
    Sorry, I had a brain fart. The command should have been
    su -c "rm /etc/X11/xorg*"
    

    I guess I had yum on the brain to much the last couple of days.
  • I ran that command but upon reboot the files 'magically' restored themselves.
  • Goineasy9Goineasy9 Posts: 1,116
    Well, sometimes they do that, but with info pertaining to nouveau. You did remove the kmod-nvidia drivers right? What was the outcome of letting it boot all the way? Did you get a black screen with a blinking cursor in the upper left hand corner of the monitor?
    Lets see what xorg.conf has in it.

    su -c "cat /etc/X11/xorg.conf"
  • when I originally ran yum remove kmod-nvidia it said that the driver is on the system but not installed, according to the boot log the nvidia driver is still being used. Thanks for taking the time to help me btw.
  • Goineasy9Goineasy9 Posts: 1,116
    No problem, Removing the kmod-nvidia might not have removed xorg-x11-drv-nvidia, so, if we just repeat everything once more it hopefully will work this time.

    Repeat these commands again and then reboot. Make sure the asterisks are in the commands.
    su -c "yum remove kmod-nvidia*"
    su -c "yum remove xorg-x11-drv-nvidia*"
    su -c "rm /etc/X11/xorg*"
    su -c "rm /etc/modprobe.d/blacklist-nouveau.conf"
    

    If xorg rebuilds itself during boot, it's okay, but it might insert "vesa" in where "nouveau" should go, but that's easy to fix. I've done this operation a few times so it should work.

    If you get a "no file found" while doing the commands, it's ok, it means they're gone.
  • Yahooo! It worked! The GUI is up and running! Thanks a million. The main reason I was trying to install the nvidia driver was that I wanted to be able to use some of the more advanced graphical effects in Fedora and such.
  • Goineasy9Goineasy9 Posts: 1,116
    YES.....I'm doing the Snoopy dance.....YES!!!!!

    OK, enjoy, have fun. Any other questions feel free to ask.

    :-)
  • Goineasy9Goineasy9 Posts: 1,116
    Hey win

    BTW - When your ready - start a new thread here in Fedora asking how to install the Nvidia drivers, and I'll help you through it. I promise, it's a lot easier than trying to fix them when they break.

    Tom
  • The only issue that I have noticed when everything was up and running is that my sound volume is extremely low even though my speakers and the volume settings are set to max. Could this be an issue with the updated kernel that was installed?

    EDIT: Never mind I was able to uncover a hidden audio control and it's working now.
Sign In or Register to comment.