Welcome to the Linux Foundation Forum!

Recently download Ubuntu...

And I'm a little new to linux, so yeah.

But I installed it and everything was fine until I tried to use the internet.

Somehow, I can't find how to connect with wireless? I'm using Ubuntu 8.04 btw.

But I'm only allowed to connect with Wired Connections, and some other connection?

I've been googling for hours but can't find a solution.

Thanks to anyone who helps me!


  • Goineasy9
    Goineasy9 Posts: 1,114
    Knowing a little more about what hardware your using would help. What type of computer, desktop or laptop, if you unfamiliar with what cpu etc., tell us a brand and model number. Also, in a terminal, can you copy and paste the output from lspci so we can see what type of wireless device the computer has.
    At a prompt when the terminal opens, just type "lspci" (without the quotes), hit enter and then copy and paste the result here.
  • I'm using a Toshiba Satellite L300D
    and the Model Number is: PSLC0E-017017EN

    This is what comes up when i type lspci into the terminal:
    00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
    00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
    00:04.0 PCI bridge: ATI Technologies Inc Unknown device 7914
    00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
    00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
    00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
    00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
    00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
    00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
    00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
    00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
    00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
    00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 02)
  • Goineasy9
    Goineasy9 Posts: 1,114
    Your laptop should have listed a pci device RTL8187B wlan-adapter. Is it possible you have a toggle switch that enables and/or disables the wifi? Could you check and let us know? Even if the driver for your wifi chip is not active, it should have been listed with lspci. Also, check to see if the wireless card is enabled in bios, I don't know why it would be turned off by default, but it is always good to check. If you do find something switched off, and are able to switch it back on, do another lspci and see if the rtl8187 is then listed. If it is, Ubuntu should be able to find a driver for you, if not, tell us and we will go on from there.
  • yeah, i have a toggle switch that enables/disables wifi, but it's enabled. i went into bios, and i couldn't see wireless card, so i just enabled all. i done another lspci, and rtl8187 is still not listed.
  • Goineasy9
    Goineasy9 Posts: 1,114
    I'm at a loss here, unless there is a hardware problem. Did the laptop come with windows, and if it did, did wifi work under windows? Is there a diagnostic program you can run, I've never used a Toshiba laptop and don't know what disks come with it. Maybe someone else here can chime in with some ideas.

    Edit: I'll see if I can google up some answers.
    Edit: sorry, it does seem like the rtl8187b has been problematic in the past, one link I found from older ubuntu forums:

    I still think that it still should show up when executing lspci, but, I'm still looking.

    Another link:
    another link with not so good news:

    Unlike my Dell, it seems that this card is on the usb bus....Can you paste the output of lsusb ? Sorry, but reading some links pointed me in a different direction.
  • yes, it came with windows, and yes, the wifi worked and i had no problems with wireless on windows.

    output of lsusb:
    Bus 006 Device 003: ID 04f2:b070 Chicony Electronics Co., Ltd
    Bus 006 Device 002: ID 0bda:8198 Realtek Semiconductor Corp.
    Bus 006 Device 001: ID 0000:0000
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
  • Goineasy9
    Goineasy9 Posts: 1,114
    Yeah, there it is. Seems like some folks have gotten the 8187b to work partially, but, I'm afraid Hardware for Linux doesn't give it very high marks.
    Bus 006 Device 002: ID 0bda:8198 Realtek Semiconductor Corp.
    The one link gave a good explanation of a patch that was tried but never 100% successful.
    This chip was offered on some Asus motherboards and advertised as a usb dongle, which would allow it to be used as a wireless access point, but, it only had drivers in windows.
    I hate to say this, and I hope someone reading this thread can prove me wrong, but I think to get wifi to work in Linux on your laptop, it would be easier to buy a wifi card and shut off the internal card, than it would be to try to get a Linux based driver to work.

    Hey, are there any other guru's here than can either confirm my findings or give a solution to the 8187b problem here?

    I'm sorry I can't help further. I will however keep looking and get back if I find anything.
  • Oh... :( Well thanks for your help anyway.
  • I currently use Ubuntu on a Dell AMD Athlon 2X64. I have ran linux on this laptop for about 3 years now, from Centos, Fedora 8, Linux Mint and Ubuntu. Generally Ubuntu with out a doubt has been the easiest to work.

    Do you have wired / wireless options, meaning do you have both? If so, can you plug your laptop so that it is using a ethernet connection rather than a wifi? Assume the answer is yes.

    Step A. Go to system > Administration>Hardware Drivers
    step A1. Ubuntu will search for available drivers.
    Step A2. Ubuntu will list Propriatary Drivers that are needed to make your laptop work properly.

    Step B. Double click Driver, activate and install I believe.

    You will need to have access to the internet however, and you will need to have updated your system and have the kernel-headers, kernel-devel, gcc updateed

    you can either use update manager, or

    sudo apt-get update install gcc kernel-header kernel-devel ,

    If this fails, please post the model of toshiba, processor, and I will get you the answers.
  • re run : lspci again, this time post Network Controller: blah blah blah WLAN, it is this line that matters most.


Upcoming Training