Welcome to the Linux Foundation Forum!

Cannot access Horizon BUI on multiple labs

dme1970 Posts: 3

I am trying to go back through labs again to prepare for COA Exam - I have been unable to get BUI access to the following labs (at least) -  2, 3.1, 3.2, 3.3, 3.4, 4.1. Myself and multiple colleagues have tried access on two different VPNs and on direct internet. Please advise.


  • serewicz
    serewicz Posts: 1,000
    edited November 2017


    Thank you for bringing this to our attention. The 3.x and 4.x labs seem to have an issue with networking which is preventing ./stack.sh from finishing. I have forwarded the information to the infrastructure support team. 

    In lab2.1 did you receive any errors during ./stack.sh?   I will continue to investigate the issue and let the support team know.



  • serewicz
    serewicz Posts: 1,000
    edited November 2017

    I have not tested all the steps, but the simple fix, so far, is to use the Pike release. so the clone command ends with  -b stable/pike. 

    The BUI looks a little different, but the steps are the same with what I've run so far. I will continue to look into the differences and update the errata file and the lab. 


  • dme1970
    dme1970 Posts: 3
    edited November 2017

    I am getting errors on running stack.sh - with both newton and pike as the releases. 

  • Was able to get stack.sh to run in Lab 2 with ocata release. 

    Unable to get 3.1 lab to start 

    3.2 lab good until need to login to BUI -(ran stack.sh with ocata relase) IP not reachable 

    It would be really helpful if we had usable labs so we are prepared for the COA Exam. 

  • I am in agreement and extremely disappointed that I paid for a course, specifically to use the labs, and it cannot be used.  If they cannot be corrected now then everyone that has paid for the course should be reimbursed.

  • eusmach
    eusmach Posts: 1
    edited November 2017

    Ping to the BUI address OK from the laptop in the local system. But connection with browsers (Chrome, IE) fails.

  • mbay25
    mbay25 Posts: 2

    Sounds like this has been a long-term issue...I'm seeing the same many months later...guess it's not just me lol

    I took this course to potentially help with teaching the skills and tools necessary for this kind of troubleshooting because I've been trying to set up OpenStack by myself using devstack as a playground but these kinds of issues are very common when playing with OpenStack; so common and so time-consuming, in fact, that I figured a Linux Foundation course on the topic may help out but it looks to be the same thing even when experts are trying to setup simple sandboxes for instructional purposes.

    If nothing else, to all the other students: if you're having these kinds of issues, congratulations, you are one step closer to learning what managing an OpenStack cloud is really like :)

    That being said, it looks like the labs are potentially useless and at best running through the course material may provide some useful information but in terms of practical experience self-guided tinkering is still the way to go...

  • It's now Sept. 10, 2018. After installing Openstack I can launch the BUI but the admin credentials are not accepted even though pass is setup in local.conf

  • serewicz
    serewicz Posts: 1,000
    edited September 2018


    Please paste your ~/devstack/local.conf file.

    Any errors in your stack log file?


  • Here it is:


    Use the following to explore new project

    enable_plugin barbican https://git.openstack.org/openstack/barbican stable/pike

    there are some errors in the logfile:
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'
    2018-09-10 16:27:42.177 | Job for [email protected] failed because the control process exited with error code. See "systemctl status devstack@
    etcd.service" and "journalctl -xe" for details.
    2018-09-10 16:27:42.188 | +lib/etcd3:start_etcd3:1 exit_trap
    2018-09-10 16:27:42.198 | +./stack.sh:exit_trap:521 local r=1
    2018-09-10 16:27:42.208 | ++./stack.sh:exit_trap:522 jobs -p
    2018-09-10 16:27:42.218 | +./stack.sh:exit_trap:522 jobs=
    2018-09-10 16:27:42.226 | +./stack.sh:exit_trap:525 [[ -n '' ]]
    2018-09-10 16:27:42.234 | +./stack.sh:exit_trap:531 '[' -f /tmp/tmp.kT3QlJM79D ']'
    2018-09-10 16:27:42.244 | +./stack.sh:exit_trap:532 rm /tmp/tmp.kT3QlJM79D
    2018-09-10 16:27:42.255 | +./stack.sh:exit_trap:536 kill_spinner
    2018-09-10 16:27:42.264 | +./stack.sh:kill_spinner:417 '[' '!' -z '' ']'
    2018-09-10 16:27:42.274 | +./stack.sh:exit_trap:538 [[ 1 -ne 0 ]]
    2018-09-10 16:27:42.282 | +./stack.sh:exit_trap:539 echo 'Error on exit'
    2018-09-10 16:27:42.282 | Error on exit
    2018-09-10 16:27:42.293 | +./stack.sh:exit_trap:541 type -p generate-subunit
    2018-09-10 16:27:42.302 | +./stack.sh:exit_trap:542 generate-subunit 1536596605 257 fail
    2018-09-10 16:27:42.730 | +./stack.sh:exit_trap:544 [[ -z /opt/stack/logs ]]
    2018-09-10 16:27:42.738 | +./stack.sh:exit_trap:547 /home/ubuntu/devstack/tools/worlddump.py -d /opt/stack/logs
    2018-09-10 16:27:43.569 | +./stack.sh:exit_trap:556 exit 1

  • serewicz
    serewicz Posts: 1,000


    Yes. If the installation does not complete you would probably not see the GUI.

    Are you running the ./stack.sh script as a non-root user?
    There may be some other errors in the log, often a few messages prior to the first exit statement. In this case the "error: 'Access denied for user 'root'@'localhost' (using password: YES)'" output would indicate the script was run as root instead of the ubuntu (non-root) user.

    What did the prompt look like when you ran ./stack.sh?


  • I do see the GUI, it won't authorize me with admin credentials as noted in the lab guide...
    no I am not running as root, but as ubuntu..

  • I did reboot and start over no change, but can do again...

  • serewicz
    serewicz Posts: 1,000

    Correct, even if you see the BUI, it does not mean the ./stack.sh process completed the installation. Often the installation fails prior to the BUI becoming available. If it did not install fully some things will not work correctly.

    The Keystone service may not be running and fully talking to Horizon. Thus it may be unable to verify the password you are using has been entered properly.

    If you see errors and an exit statement in the log file its best to assume there is a large issue and attempt to fix that issue prior to attempting access via the BUI.

    I will attempt to use your local.conf and see if I get the same error.

  • serewicz
    serewicz Posts: 1,000

    Also, when you reboot you have to run ./stack.sh again. Best would be to run ./unstack.sh then ./clean.sh then ./stack.sh to ensure everything is cleared out.

  • serewicz
    serewicz Posts: 1,000


    I noticed that when you pasted your local.conf file the line " # Use the following to explore new project ", around line 13, did not have the octothorpe ( # ) as the first character on that line. Does your local.conf have that line commented out?

    Also please could you verify the local.conf file is in the ./devstack/ directory.

    I just ran ./stack.sh after putting in the octothorpe. It worked and I can log in via the BUI. This was the end of the ./stack.sh output:

    Total runtime 1378

    run_process 24
    test_with_retry 3
    apt-get-update 6
    pip_install 344
    osc 142
    wait_for_service 17
    git_timed 241
    dbsync 32
    apt-get 72

    This is your host IP address:
    This is your host IPv6 address: ::1
    Horizon is now available at
    Keystone is serving at
    The default users are: admin and demo
    The password: openstack

    Perhaps the editor you were using removed the necessary character? Please advise if it worked once that line was properly commented or removed.


  • OK something is weird here, just refreshed as the session expired, I got a different hostname, refreshed again, and got the devstack-cc, but I think it's a clean VM with no devstack dir or openstack env..
    ubuntu@devstack-cc:~$ cd devstack
    -bash: cd: devstack: No such file or directory
    guess will repeat the whole thing and see if it's better...

  • serewicz
    serewicz Posts: 1,000

    Correct. Each session is unique.

    If you refresh, or shutdown and start over your previous work for that particular lab will be gone. We have links for each lab which allows you to run that particular section over, so you will start a new lab when you get to lab 3, and it will have previous steps done on your behalf.


  • Thanks Tim,
    Yes that line was commented out, I must have copied it from the screen skipping the hash.
    I re-did the install and now I have access to the BUI (w/o permission to the dashboard is that expected?). Hopefully things will go smoother now.

  • serewicz
    serewicz Posts: 1,000

    Glad the installation is working. When you say you don't have permission to the dashboard, what do you mean? When you select the tab does it not come up with the BUI? Could you explain the error you are receiving please.

  • It just popped up twice when I logged in to Horizon, but not blocking me from continuing... will take a snapshot next time.


Upcoming Training