Welcome to the Linux Foundation Forum!

Lab 3.2 Step 6

buch7575 Posts: 1

Lab 3.2 step 6 says to use the BUI with the public IP address of the devstack-cc node to login to OpenStack. I've tried both the 10.100 and 192.237 addresses and neither gets me to the OpenStack login page.  The 192 address gets me the default Ubuntu landing page, and the 10 adress gets me a server isn't responding message.  I've tried restarting the lab a couple times, but am wondering if I'm not getting the IP address from the correct place.




  • serewicz
    serewicz Posts: 1,000
    edited April 2017

    Hello Ed,

    You would need to use the public IP address for the node. While 10.x IP addresses are of used within an organization they do not work across the public internet. 

    In this case the issue is not with the IP address, but rather the sucessful installation of devstack. If devstack does not install completly then the web server may be working, but the OpenStack content is not available to be seen.

    There was a recent change to DevStack software which casuses the installation to fail. I think you will find errors in the log output instead of a sucessful installation.  The issue is known and a fix is being implemented. I will also be posting a work around so you can see what the fix is that the infrastructre team will be rolling out. 



  • DavidKleiner
    DavidKleiner Posts: 3
    edited May 2017

    Was there any update to this?  I am having this same problem with Lab 3.2 and don't see any work around?  When I launch the lab, devstack is already installed.

  • serewicz
    serewicz Posts: 1,000
    edited May 2017


    Yes, with the Lab 3.2 DevStack should already be installed. Please be sure to use the public IP address, not an internal one.  There are several IP addresses configured, but the 10. address the previous post mentioned is not a public IP. Look at the eth0 interface for that IP to use. 



Upcoming Training