Welcome to the Linux Foundation Forum!

Having trouble installing Linux Mint via USB

edited January 2017 in New to Linux

Hi Linux.com,

So I've been having trouble installing Linux Mint via USB due to the fact that it wouldn't boot up, even after I've followed all the steps. I found that I had a UEFI/EFI called Toshiba Setup Utility, and it has a low amount of options that I can actually change. Whenever I changed it to CSM mode, it wouldn't boot either, and would act as though nothing was on the drive or the USB.

When I visit my website to use linux the i face this problem.

Is there a way to install Linux with this EFI?


  • Showtown

    Hi I'm a novice but have just built a Linuxmint Cinnamon USB bootable flash drive, took me two goes to get it right, (didn't make the flash drive persistant)

    1 use a large miniature fast flash drive (sandisc 64gb 130mbs from Argos about 23.00 pounds. (small so it doesen't stick out and break)

    2 Download the linuxmint iso file (about 1.7gb)

    3 download the free "linuxlive USB Creator then run it. www.linuxliveusb.com/en/home

    4 plug your flash drive in

    5 the program is self explaitary but the web page gives great instructions. there are 5 sections, one of them asks for the size of persistence partition you require, it's a slider, set it to full 4gb this is required so you are able to set preferences like desktop  background image, WiFi passwords, choose to show the date etc. if you don't do this then every time you switch of you will lose the settings and have to do it all again.

    6 the last section askes if you want to format the flash drive, 'DEF yes' do you want to  hide files on the bootable usb, it doesn't matter, your also asked if you would like to boot from windows, I didn't

    7 press go, takes about 10 mins and it's done

    8 take the flash drive out, restart the PC and press (on my machine F2) to enter the bios, you have to do this before windows starts, in the BIOS select boot options, its probably set to optical (CD drive)  first and hard drive second, you need to change this to boot from 'Optical' (CD drive) first, 'External' (USB) second and the Hard drice (prob C:) third, you may have to enable 'external boot' option

    ps no mouse, use arrow key's and enter/return key

    9 put your flash drive in and restart

    10 Bingo

    Hope this helps

  • mobile
    mobile Posts: 15
    edited February 2017

    I've had issues installing a few distros on some different bios setups too. In short, I was fortunate that the systems I was installing linux on had a CD-ROM so I was able to use a bootable CD instead, however there are other methods I would have tried had that not worked such as a netinstall or an install from a image on the system hard drive.

    Also, have you tried booting the USB on another computer- possibly a newer system? At least that way you can isolate the problem is the system in question and not the USB drive.

    If you don't have a cd-rom drive, another suggestion I have is to create a new image with a different bootloader (possibly a bootloader that was popular during the time your hardware BIOS was being used- eh it's worth a shot) such as LILO or SYSLINUX (assuming you're trying to use GRUB or GRUB2).  You may have better luck, it's a relatively straight forward process that many resources online refer to-

    Good luck.

  • mykromo
    mykromo Posts: 5
    edited February 2017

    Have you tried this application?


  • mykromo

    Have you tried Linux Live USB?

    Here's the guide.


Upcoming Training