Welcome to the new Linux Foundation Forum!

Problems with getting the test env. up and running

soosgyulsoosgyul Posts: 15
edited January 2017 in LFS252 Class Forum

Please shoot me, if this is normal, but if not, please help:

Two days ago I have finally started the course. I could not do the very first lab, because as I found out two days later exactly these days, there vere some serious changes in the devstack and the lab just became outdated. ok not your fault - a headsup wouldn't hurt, but I accept that.

I got all kinds of errors, from timeouts to permission troubles.

Today when I logged to the test env. to my surprise I found that it was resetted overnight, and without error I could install git and clone this:

git clone https://git.openstack.org/openstack-dev/devstack -b stable/newton

set up the local.conf just as it is in the lab (eth2 ip addresses matched), and the ./stack.sh script finished in about 55 minutes, without any errors.

I could log in to the BUI (it was slow, but hey). I could finish the first lab, seen and found everything that was supposed to be there. Happy days. Went for lunch and other stuff, returned to the computer, woke it up, and ... it wasn't working. 

BUI - address not found, whereas lab seemed fine and double checked the eth0 ip address just in case.

No instructions on what to do next. Waited about 10 minutes, still nothing. 

./destack.sh and ./clean.sh and deleted the devstack folder and started all over again.

Now I got this:


2017-01-19 15:44:47.550 | ImportError: cannot import name opts 2017-01-19 15:44:47.644 | +lib/keystone:init_keystone:1 exit_trap 2017-01-19 15:44:47.653 | +./stack.sh:exit_trap:487 local r=1 2017-01-19 15:44:47.674 | ++./stack.sh:exit_trap:488 jobs -p 2017-01-19 15:44:47.689 | +./stack.sh:exit_trap:488 jobs= 2017-01-19 15:44:47.696 | +./stack.sh:exit_trap:491 [[ -n '' ]] 2017-01-19 15:44:47.703 | +./stack.sh:exit_trap:497 kill_spinner 2017-01-19 15:44:47.709 | +./stack.sh:kill_spinner:383 '[' '!' -z '' ' ]' 2017-01-19 15:44:47.716 | +./stack.sh:exit_trap:499 [[ 1 -ne 0 ]] 2017-01-19 15:44:47.723 | +./stack.sh:exit_trap:500 echo 'Error on exit' 2017-01-19 15:44:47.723 | Error on exit 2017-01-19 15:44:47.729 | +./stack.sh:exit_trap:501 generate-subuni t 1484839640 1047 fail 2017-01-19 15:44:48.327 | +./stack.sh:exit_trap:502 [[ -z /opt/stac k/logs ]] 2017-01-19 15:44:48.345 | +./stack.sh:exit_trap:505 /home/ubuntu/de vstack/tools/worlddump.py -d /opt/stack/logs 2017-01-19 15:44:49.275 | +./stack.sh:exit_trap:511 exit 1

Now my options.

  1. Wait another couple of days, until it hopefully resets itself.
  2. There is a secret reset command and in about an hour I am at ground zero
  3. I did something wrong, and there is an easier way to deal with all this.

Honestly, I'm getting fed up with this course. 

I know this is not the proper attitude, and in IT there are always problems, but this is a course for crying out loud. Paid money for it and everything.

Please help.

Comments

  • serewiczserewicz Posts: 500
    edited January 2017

    Hello,

    Indeed, each lab environment will time-out in a 24 hour period. I'm not exactly sure the time, but it is usually a long time. My thought is there may have been either an inactivity issue or the back-end had some issue while you were away and the connect was broken.

    I do know when I have left a lab up over night it will go away.   As for a reset, In the upper right of the window you will find there is a "start over" and  a "quit" button. Should you need to start the same lab fresh again the fastest way is to "Start over'. The spawn tends to take about 15 minutes.

    The liberty release went EOL then disappeard from openstack.org, so the update to Newton is on its way. Soon. Hopefully very soon. 

    Regards,

Sign In or Register to comment.