Welcome to the Linux Foundation Forum!

Acer Aspire 5720 with Linux Mint 18 Sarah Cinnamon

Gwynny Posts: 1
edited November 2016 in New to Linux

I have installed Linux Mint on other computers with success and enjoyed using it and even set up one for a friend who has been using it to surf the internet for a couple of years, but it has always worked perfectly from installation and I've never had problems with hardware not working before. I installed it onto my daughter's old Acer Aspire 5720 recently, but I cannot get it to connect to the wifi internet. I tried a USB wifi reciever, but this didn't work either. Can anyone help me to get the wifi going on this laptop? I'm very good with Windows PCs, but, unfortunately, don't understand any of the Linux jargon, so your instuctions need to be very detailed and please dont assume I will know how to install drivers etc. I have Virgin Media internet and using the newest router. The laptop has only 80gb of hard drive which is why I had to give up on Windows completely.


  • saqman2060
    saqman2060 Posts: 777
    edited November 2016

    When you installed Mint on your daughter's laptop, did the system show a network icon on the taskbar? An icon that looked like a disconnected computer? When you click the icon, what network options do you see? 

    It is not uncommon that Linux does not have drivers for some laptop wireless controllers. If this appears to be the case, we will have to do some grease work. First, lets make sure the problem is not human related.

  • saqman2060

    Are these the specs to that laptop?


    What kernel version are you using?

    uname -a

    Type the above command in a terminal that is available on your mint system.

  • Showtown

    Hi, I'm really really new to Linux. Yesterday I made a bootable USB flash drive (64gb sandisc ultra). using 'Linuxmint Cinnamon'. after setting bios boot options, it works great. There are a few snags which Im working through at the moment though. Like yourself I could not get onto WiFi, no matter how many times I put the WiFi key in each time the network dissapeared from the list, I had to turn WiFi off and on to see it again. I can get it to connect though,

    Try this - click the WiFi icon on the task bar (two diagonal triangles)

    at the bottom of the window click 'network settings' in the window left pane select WiFi. 

    find your network in the right pane and click the 'arrowed connect button', a small window opens, Don't put your WiFi key in, just close the window.

    'preference button' appears, click it, a new window opens, select 'security', enter your WiFi key and 'apply'

    now press the 'arrowed connect button'

    It worked for me, but It won't remember, you have to do this every time you boot up. At least you will know if you have drivers installed.

    Good luck

    Please Note

    I have just rebuilt my flash drive, I hadn't created it with a persistant drive partition, this is needed to store settings when shutting down the PC, without it backgrounds, WiFi keys, keyboard styles etc wont store, it also cured my getting on line prob. I have replied to another post detailing how I made the bootable flash drive using Linuxlive USB Creator.


Upcoming Training