Welcome to the new Linux Foundation Forum!

Task 2: Deploy a Monitor step 2

jimmyaeadyjimmyaeady Posts: 10
edited November 2016 in LFS252 Class Forum

When attempting to yum install ceph-deploy I receive the error "Package python-setuptools-0.9.8-4.el7.noarch is obsoleted by python2-setuptools-22.0.5-1.el7.noarch which is already installed"

How can I resolve this? Uninstalling teh current Python2-setuptools and installing the tool that is requested?  --skip-broken and rpm -Va --nofiles --nodigest did not resolve the issue

 

 

[[email protected] ceph-cluster]$ sudo yum -y install ceph-deploy

Loaded plugins: fastestmirror, langpacks, priorities

Loading mirror speeds from cached hostfile

 * base: mirror.rackspace.com

 * epel: fedora-epel.mirror.lstn.net

 * epel-debuginfo: fedora-epel.mirror.lstn.net

 * epel-source: fedora-epel.mirror.lstn.net

 * extras: repos.dfw.quadranet.com

 * updates: mirrors.advancedhosters.com

Resolving Dependencies

--> Running transaction check

---> Package ceph-deploy.noarch 0:1.5.36-0 will be installed

--> Processing Dependency: python-distribute for package: ceph-deploy-1.5.36-0.noarch

Package python-setuptools-0.9.8-4.el7.noarch is obsoleted by python2-setuptools-22.0.5-1.el7.noarch which is already installed

--> Finished Dependency Resolution

Error: Package: ceph-deploy-1.5.36-0.noarch (ceph-noarch)

           Requires: python-distribute

           Available: python-setuptools-0.9.8-4.el7.noarch (base)

               python-distribute = 0.9.8-4.el7

 You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest

 

Comments

  • serewiczserewicz Posts: 506
    edited November 2016

    I will look into this. We may need to disable or enable some repos or move to a newer version of ceph. It will take me a bit to reproduce the lab to this point.

  • jimmyaeadyjimmyaeady Posts: 10
    edited November 2016

    This is an important lab for me but I will skip this lab and carry on until I hear a response from you. 

  • serewiczserewicz Posts: 506

    I am updating the errata file. I will push more details about the lab, and what will be different with following steps shortly. To fix this particular issue:

    The installation of the ceph-deploy script has changed. The python software has a newer version, but the older installation script is not aware of it, nor willing to use a newer version. To fix this, replace yum -y install command with a python specific commands as follows:



    [[email protected] ceph-cluster]$ sudo yum -y install python-pip

    [[email protected] ceph-cluster]$ sudo pip install ceph-deploy

    [[email protected] ceph-cluster]$ sudo pip install --upgrade pip

    That will get you past that point. The errata should be up with following changes if you haven't figured out how to fix the issue through troubleshooting before then. 

  • Abdenour7496Abdenour7496 Posts: 9
    edited November 2016

    Hi serewicz

    in TASK2 LAB11.1 i followed your advise and tried to install the python-pip BUT i am receiving this error>>

    [[email protected] ceph-cluster]$ sudo yum -y install python-pip

    Loaded plugins: fastestmirror, langpacks, priorities

     

    File contains parsing errors: file:///etc/yum.repos.d/start-ceph.repo

            [line  9]: 10.100.32.41         rdo-cc

    PS NOTE: i am typing the command in the CLI not copying and pasting the command

    Any help please

  • serewiczserewicz Posts: 506
    edited November 2016

    Hello,

    The output to an error is a good place to start. You'll note it says the file, start-ceph.repo, has a parsing error on line 9. I would not know why a line from what looks like /etc/hosts, would end up there.   Did you use the "start over" feature, or have are you continuing with the previous session you had been working and troubleshooting on?

    You may consider looking at the edX course on learning about Linux System Administration.  OpenStack is an advanced topic and has the prerequisites you have the knowledge found in LFS101 (free - link below) and LFS201. Troubleshooting yum issues would be one of those skills. 

    https://training.linuxfoundation.org/linux-courses/system-administration-training/introduction-to-linux '

    If you "start over" and it still does not work, please troublshoot the errors from the terminal. I ran the very steps from the course on duplicate lab system shortly before my previous post. I encountered no issues. 

Sign In or Register to comment.