Welcome to the Linux Foundation Forum!

Exercise 2.1 Installing DevStack fails


Comment out the following lines.  



#FIXED_RANGE= #Range for private IPs

#FLOATING_RANGE= #Range for public IPs



  • serewicz
    serewicz Posts: 1,000

    Thank you for posting a fix.

    If you use DevStack with Neutron networking you no longer need to pass parameters for fixed and floating IP addresses. These values are still necessary if you use Nova networking as would be found in the Liberty release.

  • steinm88299

    Did an unstack.sh and clean.sh. Commented out the local.conf as specified. Still getting keystone errors and the UI is just the generic Ubuntu/Apache banner.

    2016-08-18 22:48:34.592 | +functions:wait_for_service:396            rval=124

    2016-08-18 22:48:34.603 | +functions:wait_for_service:401            time_stop wait_for_service

    2016-08-18 22:48:34.615 | +functions-common:time_stop:2372           local name

    2016-08-18 22:48:34.621 | +functions-common:time_stop:2373           local end_time

    2016-08-18 22:48:34.627 | +functions-common:time_stop:2374           local elapsed_time

    2016-08-18 22:48:34.632 | +functions-common:time_stop:2375           local total

    2016-08-18 22:48:34.638 | +functions-common:time_stop:2376           local start_time

    2016-08-18 22:48:34.644 | +functions-common:time_stop:2378           name=wait_for_service

    2016-08-18 22:48:34.650 | +functions-common:time_stop:2379           start_time=1471560454

    2016-08-18 22:48:34.665 | +functions-common:time_stop:2381           [[ -z 1471560454 ]]

    2016-08-18 22:48:34.669 | ++functions-common:time_stop:2384           date +%s

    2016-08-18 22:48:34.672 | +functions-common:time_stop:2384           end_time=1471560514

    2016-08-18 22:48:34.678 | +functions-common:time_stop:2385           elapsed_time=60

    2016-08-18 22:48:34.683 | +functions-common:time_stop:2386           total=0

    2016-08-18 22:48:34.689 | +functions-common:time_stop:2388           _TIME_START[$name]=

    2016-08-18 22:48:34.694 | +functions-common:time_stop:2389           _TIME_TOTAL[$name]=60

    2016-08-18 22:48:34.699 | +functions:wait_for_service:402            return 124

    2016-08-18 22:48:34.705 | +lib/keystone:start_keystone:607           die 607 'keystone did not start'

    2016-08-18 22:48:34.710 | +functions-common:die:186                  local exitcode=0

    2016-08-18 22:48:34.716 | [Call Trace]

    2016-08-18 22:48:34.716 | ./stack.sh:1015:start_keystone

    2016-08-18 22:48:34.716 | /home/ubuntu/devstack/lib/keystone:607:die

    2016-08-18 22:48:34.720 | [ERROR] /home/ubuntu/devstack/lib/keystone:607 keystone did not start

    2016-08-18 22:48:35.724 | Error on exit 

  • serewicz
    serewicz Posts: 1,000
    edited August 2016

    Please post other errors or warnings from the stack.sh.log file. I see the portion where keystone is failing, but the networking issue that probably led to the issue is not shown.   When the network is configured with the stack.sh script there are a few changes made. The clean.sh and unstack.sh scripts do not undo those changes.   

    Please select the "Start over" button in the upper right of the window. After running the lab again, should you get an error, please look farther up the log to find other errors that would prevent Keystone from starting properly.

  • serewicz
    serewicz Posts: 1,000

    For some reason the barbican release, even the older liberty version, ties to use  API v3 commands. It shouldn't, but still does. As a result, please omit or comment out that line from the local.conf file. 

    If barbican were to work properly we could call the older version via the local.conf file with an entry like this:

    enable_plugin barbican https://github.com/openstack/barbican stable/liberty


  • neghtedari
    neghtedari Posts: 12
    edited August 2016

    Thank you as usual Serewicz, that did the trick, how do you figure these things out? when I face a problem like this, there is no way I can relate barbican to the issue on the Horizon webpage, I would appreciate it if you share some of your tricks with us :-)

  • neghtedari
    neghtedari Posts: 12
    edited August 2016

    I'm also having issues with Lab 2.1, as suggested in other posts here, I tried to install devstack, using below git clone command :

    git clone https://git.openstack.org/openstack-dev/devstack -b stable/liberty

    I got whole bunch of errors at the end but much to my suprise, I could actually access the Horizon page and login to it but now the new problem is that it is not able to detect anything , when I click on any button , it says "Unable to retrieve instanses"

    I tried to Start Over the lab once and still observing the same issue here. at least this error can be reproduced , i'm glad there is some consistency :-)

    Any help would be very much appreciated

    Here is the local.conf file :













    enable_plugin barbican https://git.openstack.org/openstack/barbican

    enable_service rabbit mysql key

    Here is the error lines log file :

    ubuntu@devstack-cc:/opt/stack/logs$ cat stack.sh.log |grep -E error

    2016-08-25 16:35:14.082 | + sudo rm -f /var/log/apache2/horizon_access.log /var/log/apache2/horizon_error.log

    2016-08-25 16:35:34.609 | + tail_log horizon /var/log/apache2/horizon_error.log

    2016-08-25 16:35:34.609 | + local logfile=/var/log/apache2/horizon_error.log

    2016-08-25 16:35:34.624 | + screen_process horizon 'sudo tail -f /var/log/apache2/horizon_error.log'

    2016-08-25 16:35:34.624 | + local 'command=sudo tail -f /var/log/apache2/horizon_error.log'

    2016-08-25 16:35:37.672 | + screen_rc horizon 'sudo tail -f /var/log/apache2/horizon_error.log'

    "'16-08-25 16:35:37.675 | + echo 'stuff "sudo tail -f /var/log/apache2/horizon_error.log

    2016-08-25 16:35:37.675 | + screen -S stack -p horizon -X stuff 'sudo tail -f /var/log/apache2/horizon_error.log & echo $! >/opt/stack/status/stack/horizo

    '.pid; fg || echo "horizon failed to start" | tee "/opt/stack/status/stack/horizon.failure"

    2016-08-25 16:36:58.440 | openstack user create: error: unrecognized arguments: 38f50c621b7c412b9334e7b7a82badeb 4f8fecb87cb5404ba68ba3a622289ffd f9957d1c

    3b604ddb906a54c8e5696e93 barbican

    2016-08-25 16:37:00.112 | openstack role add: error: unrecognized arguments: 38f50c621b7c412b9334e7b7a82badeb 4f8fecb87cb5404ba68ba3a622289ffd f9957d1c3b6



  • serewicz
    serewicz Posts: 1,000
    edited September 2016

    Log files and lots and lots of time working with the product. OpenStack changes so fast documentation cannot keep up. Review output and log files, look for errors that happen before the obvious error to determine what kind of thing was happening and some guessing. I wish I could pass along a secret sauce recipie, but its mostly days and days of working with it until the stuff makes sense.

    Glad it worked! Thanks!


Upcoming Training