Welcome to the new Linux Foundation Forum!

Video issue

RickSMORickSMO Posts: 123

Ok, the issue I had with the new linux kernal and my video that I solved has a new issues caused by the old problem. Even tho I set my default monitor settings to where it works now after installing my new video driver, now only in the log in screen it is no input, i turn my monitor on, log in, and poof I get my screen back (because the default settings I made kick in) How do I fix this?

Comments

  • marcmarc Posts: 647
    RickSMO wrote:
    Ok, the issue I had with the new linux kernal and my video that I solved has a new issues caused by the old problem. Even tho I set my default monitor settings to where it works now after installing my new video driver, now only in the log in screen it is no input, i turn my monitor on, log in, and poof I get my screen back (because the default settings I made kick in) How do I fix this?

    Hardly advisable without knowing anything about your system... DE? Processor? graphics card?
  • RickSMORickSMO Posts: 123
    Continuation of a issue I thought I had previously resolved.

    ATI Radeon HD 4850

    AMD Phenom II 910 (Quad Core) 2.6 ghz

    8GB DDR3 RAM

    Anything requiring 3D acceleration is not working as well...


    whats your abbreviation DE for?
  • RickSMORickSMO Posts: 123
    My 3D acceleration issue has been fixed, all that is left is a simple issue with my boot screen being completely black and blank until I log in to my desktop then its fine.


    I found a website that showed how to install the .xorg driver for Fedora 13 for my video card, it fixed my issue in Fedora 15 so far, Savage2 seems to be running great now.


    Would like my boot screen issue fixed tho, not sure where to start?
  • marcmarc Posts: 647
    RSims wrote:
    yum install kmod-catalyst xorg-x11-drv-catalyst xorg-x11-drv-catalyst-libs.i686

    running this after I installed the proprietary drivers fixed my 3D acceleration issue.

    Could you share your xorg.conf file?

    DE = Desktop Environment <--- GNOME, KDE, XFCE...

    Regards
  • RickSMORickSMO Posts: 123
    Using KDE

    Here is my xorg.conf file:

    # Xorg configuration created by livna-config-display

    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "Screen0" 0 0
    EndSection

    Section "Files"
    ModulePath "/usr/lib64/xorg/modules/extensions/catalyst"
    ModulePath "/usr/lib64/xorg/modules"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    Option "OpenGLOverlay" "off"
    BusID "PCI:2:0:0"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection
  • RickSMORickSMO Posts: 123
    it's kind of like a extra layer of security that I don't want and didn't ask for, because on boot up I can type my password in with a blank screen. Then my screen comes back as soon as I'm logged in. lol
  • marcmarc Posts: 647
    RickSMO wrote:
    it's kind of like a extra layer of security that I don't want and didn't ask for, because on boot up I can type my password in with a blank screen. Then my screen comes back as soon as I'm logged in. lol

    Hehehehe I doubt it's a security layer ;)

    I'm assuming "log in screen" means the KDM screen.

    I know KDE added some scripts for initial config of the displays in KDE 4.6.x

    What you are describing seems to be a problem with the resolution or something like that. The default res, for some reason, is not working and that's why you get a blank screen whenever on KDM. However, when you login into kde the scripts I mentioned set the correct resolution and that's why you get the screen back on.

    Could you please try adding the proper resolution to the xorg.conf file?

    In the "Screen" section add something like:
    	SubSection "Display"
    		Depth		24
    		Modes		"1680x1050"
    	EndSubSection
    

    You can test if the problem is what I'm describing. When you get to the KDM screen don't log in. Switch to a TTY with Ctrl+Alt+Fx and login in there. Then:
    DISPLAY=:0 xrandr -q
    
    (I'm assuming :0 is the default display)

    And check what it outputs. Compare that to what you see if you run that when you are in KDE

    Regards
  • RickSMORickSMO Posts: 123
    well i'm sure its the resolution or something similar, the issue I had when i initially installed the driver was that my screen was black and stayed black, for some reason it set my monitor to a refresh rate of 43 hertz and it can't run at that slow of speed. So I set it to auto and it kicks in when i log in. i'll try what you mentioned and let you know what happens.
  • RickSMORickSMO Posts: 123
    not able to get permission, i went to terminal and logged into root with su, then dragged and dropped the file into it and it still claims i don't have permission. What am I doing wrong lol
  • marcmarc Posts: 647
    RickSMO wrote:
    not able to get permission, i went to terminal and logged into root with su, then dragged and dropped the file into it and it still claims i don't have permission. What am I doing wrong lol

    I'm not sure I'm following you here. Dragging and dropping in a terminal?

    You mean that you do not have write permissions? If that's the thing, check you do have write permission because even if you own the file the flags might be not to able to write on the folder/file.

    Regards
  • Goineasy9Goineasy9 Posts: 1,116
    Not an answer for the graphics question, but, I have Krusader installed and have Krusader root mode on my panel. When I want to drag and drop files as root, that's what I use. It also makes a lot of small editing easier. Very useful app.
  • RSimsRSims Posts: 146
    I still can not get write permission to my xorg.conf file. maybe I am doing something wrong... How do you normally do it Marc? I tried Krusader GoinEasy, I didn't see how to use it for this situation. Help! lol.
  • Goineasy9Goineasy9 Posts: 1,116
    Look for Krusader Root-Mode, it may be in System menu. I'm not home to look. I keep the Icon on my top panel.
  • RSimsRSims Posts: 146
    GoinEasy9 I got it with Krusader, thanks for the help! I made the change now i'll reboot and try what else was suggested.
  • RSimsRSims Posts: 146
    I tried DISPLAY =0 ,1 and 2 all of them say "Can't open display x"

    Suggestion?
  • Goineasy9Goineasy9 Posts: 1,116
    I use nouveau, not the nvidia driver, I have no xorg.conf.

    The open source radeon driver should work with your card though. I'm going to have to reread the thread, did you install the Catalyst driver from AMD?
  • RSimsRSims Posts: 146
    it works great, the only thing I don't have is my log in screen, I type my password into a blank screen and press enter. Then everything works great and 3D acceleration is perfect. Just the annoying issue of my log-in screen not working, I get "Input not supported" at it.
  • Goineasy9Goineasy9 Posts: 1,116
    Try:
    Menu-->System Settings-->System Administration-->Login Screen-->Theme

    And see if you can set the login screen to something that shows up. The Lovelock theme is default, make sure it's either set for that, or, see if one of the others works.
  • RSimsRSims Posts: 146
    it seems.... my fedora crashed....
  • Goineasy9Goineasy9 Posts: 1,116
    When you get a chance, please explain what you mean by crashed. Exactly what is going on, what do you see during that crash? Or have you worked it out?
    Sorry I had a long day at work and didn't see your post earlier.
Sign In or Register to comment.