Welcome to the new Linux Foundation Forum!

Installing Driver for ASUS USB-N 13 Ahhhh!

kd5ywakd5ywa Posts: 28

:blink: Ok.. A whole day of my life has been flushed down the drain in a frenzy of Google Searches and phone calls, and I hate to be the newby to ask a, more then likely, stupid question of all of you.

1. I have a disk that came with my ASUS USB-N 13 Wireless Adaptor.

2. How do I use it, to install "what ever it is" to my Fedora 15 to make it work. And I need some real step by step. Imagine as if you are trying to tell you grandmother how to do it.

I do appologize, I do internet trouble calls for a cable company and can work the rear end out of Winblows, but this Linux stuff is rough. I switched to Linux for security purposes, and I am devoted to learning it.... But I just have to get this USB Wireless adaptor to work so I don' t have to run a 75 foot ethernet cord, in a two story house!

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    First of all, we need to see what chip is in that usb adapter. In a terminal type,
    lsusb
    
    and, either give us the whole output, or, the line that has wireless or wifi in it. That should contain the info about the chip.
  • kd5ywakd5ywa Posts: 28
    Bus 001 Device 002: ID 0b05:1784 ASUSTek Computer, Inc. 802.11n Network Adapter
  • Goineasy9Goineasy9 Posts: 1,116
    There's a long post here describing some problems folks from fedora had while trying to get the driver to work, although it seems that in the end, they did get it working. This was on a older version of fedora, Fedora 14, but it's a good reference.
    http://forums.fedoraforum.org/archive/index.php/t-259280.html

    You would install the rt3070 driver by entering, in a terminal, as root:
    yum install akmod-rt3070
    
    Then reboot. Rebooting builds the driver module.

    It's required that the rpmfusion repos be enabled in order to get akmod-rt3070 You can install them by right clicking on the fedora 15 versions, then, let packagekit do the installation for you. If you don't have them enabled, you can acquire them here:
    http://rpmfusion.org/Configuration

    Read over the thread from the first link I posted first, in case you have problems during the installation. Since this is Fedora 15, the problems that they had in Fedora 14 should be fixed. At least i hope so.

    I hope it works the first time for you, if not, let us know. It's late here, but, hopefully someone will be around to answer.
  • RSimsRSims Posts: 146
    This may have been tried already, but have you checked the manufacturers website for the correct driver needed for your system? Most do include linux drivers on their site as well as windows. Then you can simply download it, install it. Its worth checking just because they keep the most updated version on their site.

    P.S. I'd do this after doing what GoinEasy recommended. But only if your issue is not resolved (if it gets resolved, quit fixing it). Unless your ready to break it, and fix it again, which usually turns out to be worth it.
  • kd5ywakd5ywa Posts: 28
    Ok.. Round two with the Linux Machine.

    The yum install akmod-rt3070 driver installed correctly, but my Machine says

    lo no wireless extenstions

    p2p1 no wireless extenstions

    wlan0 IEEE 802.11bgn ESSID:off/any
    Mode: Managed Acess Point: Not-Associated Tx-Power=) dBm
    Retry Long Limit:7 RTS thr: off Fragment thr: off
    Encryption Key: off
    Power Management:on

    Now....what doses all that mean? I see that it see the Wireless card, but what is it that I must do now to get this thing to work?

    Feel free to stone me when you are done.
  • Goineasy9Goineasy9 Posts: 1,116
    Ha, at present I'm out of stones.

    On my laptop, when the wireless is turned off (physical switch off) I see this from iwconfig:

    [[email protected] ~]$ iwconfig
    lo no wireless extensions.

    wlan0 IEEE 802.11 Nickname:""
    Access Point: Not-Associated
    Link Quality:5 Signal level:0 Noise level:0
    Rx invalid nwid:0 invalid crypt:0 invalid misc:0

    eth0 no wireless extensions.

    Yours says "Managed Access Point", is that how it was advertised? I'm just wondering, because, it may be a problem. I'm going to have to read over that link I gave you to see if there are more answers. I'm wondering if there's a way to switch off the access point and just use the wireless adapter. I've got appointments this afternoon, I'll see if I can come up with something a little later.
  • kd5ywakd5ywa Posts: 28
    Awsome,...I will look too, the adaptor does appear to have a light on it, that is not on....

    You do have a point about the "Managed Access Point" would disturb me, if I saw it with a internet customer using windows.

    Out source program? Third Party?
  • Goineasy9Goineasy9 Posts: 1,116
    It seems the Access Point is referred to as to whether it is present or not, my iwconfig when wireless is enabled.

    lo no wireless extensions.

    wlan0 IEEE 802.11 Nickname:""
    Access Point: Not-Associated
    Link Quality:3 Signal level:188 Noise level:165
    Rx invalid nwid:0 invalid crypt:0 invalid misc:0

    eth0 no wireless extensions.

    So, I'm not certain if your usb stick is meant to be a access point or not. When I see Access Point I always think back to my own problems. Anyway.

    In order to get my wireless up and running on Fedora 15, I had to click on the icon for Network Manager and check off enable wireless. Even though my wireless switch was on (computer switch), I still had to enable it in Network Manager. Since my router uses WPA2 security, I also had to go into Network Manager and set up the security to match the router. It was a bit frustrating because I would assume that Network Manager would automatically enable the wireless after the switch on my computer for wireless was turned on, but, it took me configuring Network Manager for it to work.

    If you click on the Network Manager icon, the "enable wireless" checkbox should be on the bottom left.
  • kd5ywakd5ywa Posts: 28
    I don't have a network manager... I have "Network" and "Network Connections" ..... I do have a Wicd Network Manger but when I click on it, it says "Failed to launch 'Wicd Network Manger- faile to execute child process "wicd-gtk" (no such file of directory)"

    One thing is I went to "Network" and clicked to disable the wireless, then enable it, and guess what, it worked to the first page, then when I went to some random website, like ebay, it told me I was working offline, and to click it off the 'Working offiline" option under file. So I did, then, no more internet.

    I will see... what eles I can do.
  • Goineasy9Goineasy9 Posts: 1,116
    As that long thread showed in my original post, this wifi chip and the corresponding driver are problematic. At least you have the driver installed and it did originally work. BTW - My Network window says Network Connections also, it is, in fact, Network Manager., just so we know that we're talking about the same thing.

    I haven't had time to go through that thread to see if there are any tweaks that could be done. At the moment just make sure wireless is checked and enabled and "Connect Automatically" is checked in Network Connections under the Wireless (use the edit function to look into your connection), and hope we can come up with a tweak to make sure the connection doesn't drop once initiated. You could also experiment with wicd, although I haven't used that in a while, you never know, since you now have the driver installed, if it will work better.

    I'll let you know if I find anything else.

    Tom
  • kd5ywakd5ywa Posts: 28
    ok, I played around with it, and I switched out the Netgear USB Wireless card N150, and I have different readings under iwconfig....

    wlan1 IEEE 802.11bgn ESSID:off/any
    Mode: Managed Access Point: Not-Associated Tx - Power=20 dBm
    Retry long limit:7 RTS thr: Offf Fragment thr:off
    Encryption key; off
    Power Management: off

    Well, at least I have 20dBm of power this time and under "Network" it says "Dissconected. Which is more than I had.

    You gave me an idea to try the other usb card, when you said, at least you have the driver loaded.

    I will keep trying with both!

    Thanks

    Also, any one eles with any ideas?
  • kd5ywakd5ywa Posts: 28
    IT WORKS WITH THE NETGEAR AFTER A REBOOT!!!!!!!!!!!!!!!

    :blink:
    AHHHHHH!!!!

    :laugh:

    YES!
    B)

    THANKS!
  • kd5ywakd5ywa Posts: 28
    I believe that I should explain a bit more as to what I did incase it could help someone else.

    After I put the NetGear USB Wireless Adaptor in the computer, it began to blink, but said disconnected.
    So I staticed the IP address using the Subnet Mask, Gateway, and DNS from my window 7 system. I accessed my router for an open IP address, then rebooted.

    And it worked.

    So once again, Thinks, and
    ps... the ASUS works great with my Window, so no loss there!
  • Goineasy9Goineasy9 Posts: 1,116
    Hey, great news. Well, if switching the adapters works for you, if it works, don't fix it, heh. Glad we helped get you online with your Linux install, even if it wasn't the way we originally planned.
Sign In or Register to comment.