Welcome to the new Linux Foundation Forum!

usb wireless modems in oz

Hello,

Here in oz we have a problem with ISP's not providing support for Linux on their modems. I asked a Telstra Bigpond tech why not and he said that linux is too hard, get another operating system. I can't keep Windows going here, it is not hard enough so at present am denied access to internet at home. A independant tech tells me that it would only take them half an hour to make the modems compatable with Linux. I think i know why they don't but better not say................Jed Stuart

Comments

  • mfillpotmfillpot Posts: 2,180
    Even though their support teams will not help you to setup the usb modem does not mean that it will not work. In most cases you can plug it into your system and use a tool like kppp, gnome network manager or wvdial to configure it to make the connection.

    The issue we have with companies supporting Linux is that windows support techs are a dime a dozen because they are used to restricted functionality and are not necessarily trained for in depth usage support or allowing the users to run different configurations. Due the the large amount of available applications Linux has to fill a specific need and the available options for each application, this can be hard to support because it would require further training for their support techs which can be costly

    Just remember that just because their support lines will not help you, it does not mean that it will not work. My recommendation is to look for a Linux User Group in your area and it is very likely that you can find someone in such a group that can easily help you to setup your modem.
  • Jed SJed S Posts: 10
    thanks for your help, have a good day.
  • Jed SJed S Posts: 10
    I am struggling a bit to understand this but there seem to be two issues. The compatability of the modem with Linux would seem to be an easy thing for Telstra to design into it. Optus here have done that now but are still not providing technical support. On the technical support issue I am wondering if there is a way of clarifying the boundaries of support so that it can be simpler for them. I previously attempted to get a Maxon BP3 modem working using James Camerons program for the Asus Eeepc. It worked for one session perfectly then for a year the connection to Telstra would be achieved but then a message "No USIM present, or username or password wrong." I get a lot of DOS attacks and usually the ISPs cant do anything about it anyway, but I at least wanted to ge them to try. The point I am getting at is could a destinction be made between issues that relate to the operating system and those that are to do with what happens in the online environment or at the ISP itself. They should be able to gaurantee some of that perhaps?
  • mfillpotmfillpot Posts: 2,180
    The distinction is easy to achieve when using a cable of DSL modem, basically telling them that their responsibility ends when it becomes you network generally works. But when using a usb modem their support responsibility is all of he way down to the computer which is needed to make the connection.

    By asking the right questions you can still receive support, but when it gets to that point you know more than the support tech and are only calling them for confirmation of configuration information. If you can get network manager to recognize the usb modem and get into the configuration screen then a simple call to the ISP should give you the username, password, cal-in number and optional baud-rate. But again I have not used the fedora network manager and do not know exactly what settings are available.
  • woboylewoboyle Posts: 501
    Most current USB wireless modems are supported by current versions of Linux such as Ubuntu. Another solution is to get an unlimited data plan on your cell phone, then get an Android phone with Froyo (Android 2.2) so you can tether it as a USB cell modem. So, what is the make+model of modem(s) they will provide you? Let us know and we can check it out with regard to Linux compatibility.
  • Jed SJed S Posts: 10
    The modem that Telstra provides is a Sierra aircard 312U. I just now found out from Sierra the instructions on how to get it working with Linux although I am not yet sure whether this is going to work with Linux on an Asus Eeepc.
  • Goineasy9Goineasy9 Posts: 1,116
    Check this out ... Sierra Support using Linux

    And let us know if it helps.
  • Jed SJed S Posts: 10
    The modem is a Telstra Ultimate (AC 312U) made by Sierra. it turns out that Sierra does provide us with instructions on how to make it work but we have to find it ourselves and doesnt provide any support. The instructions are quite clear though but there is a problem with the modem hanging up which so far alludes us.
  • woboylewoboyle Posts: 501
    I have a Sierra 595U AirCard that I used for several years on Sprint here in the US with Windows, several versions of Ubuntu Linux, and Mac OSX - never a problem. If you are getting connected, but then it disconnects randomly, perhaps it is one of these problems:

    1. The carrier is dropping the connection if it is inactive for awhile.
    2. There is a fault in the modem - the fact that it connects means that you don't have a system software problem.
    3. Your system is going into sleep or hibernate mode - this causes the connection to be dropped. It may take a number of seconds before it reconnects after the system wakes up. There were problems with this reconnection not happening after sleeping in the past, so that may be an issue (kernel version).
    4. How you have configured the connection in the network manager or PPP configuration file(s).
Sign In or Register to comment.