Welcome to the Linux Foundation Forum!

Wireless networking with Atheros chip set

jfoz Posts: 4

I'm wondering if anyone else has experienced this with their computers and wireless networks. I have three laptops that have Atheros wireless adapters in them, a Toshiba, a Lenovo and an eee pc. The Toshiba is the oldest and dual boots WinXP and Arch Linux, the Lenovo dual boots Vista and Arch and the eee dual boots XP and Arch. I use Arch on these machines pretty much exclusively. I had a really nice network set up at home and recently my DSL modem died and had to be replaced. I had a WRT54G wireless router that works flawlessly with everything in the network but when the DSL went out AT&T send a 2Wire modem/wireless router so I had to take the WRT54G out of service and use the wireless router part of the 2Wire. Now here are where my issues came up, the machines with the Atheros chips weren't able to connect to the wireless network, they were properly configured and all but they wouldn't connect. The Toshiba I rebooted to XP and it connected fine, then rebooted and then it connected fine. My wife's eee which runs the stock Asus Zandros distro wouldn't connect either.

I also have experience difficulties connecting to a dlink router with my Lenovo in Linux as well, with Vista it connects fine. My eee connects everytime to the dlink using Linux I don't know why.

So has anyone experienced the same issues with the Atheros chips in Linux connecting to various wireless routers?


  • justifier
    justifier Posts: 1
    Have you tried in both DCHP mode and static ip mode? Some eeePC's where having problems with wireless networks, the older ones but an update fixed them, i think.
  • jfoz
    jfoz Posts: 4
    It's not just he eee that doen't connect, it's the lenovo and the toshiba as well but only under Linux, XP and Vista work fine. Really wonder if there is something in the proprietary software in the dlink, 2wire etc routers that cause the Linux operated pc to be unable to connect. With my WRT which runs Linux I never had that problem.
  • mfillpot
    mfillpot Posts: 2,177
    It sounds like the dhcp daemon in the router is not recognizing the dhcp requests that are coming from your devices. I don't think the problem is with the devices, but rather a conflict between the dhcp daemon and dhcp client software. I would recommend trying another dhcp client software in your Linux installations.
  • jfoz
    jfoz Posts: 4
    Ok, I'll give that a try and see if it makes a difference.
  • jfoz
    jfoz Posts: 4
    Well that didn't make a difference. Two computers using the same software and distro (Arch, using wicd and dhclient), one won't connect to the router (a dlink product) in Linux but will with Vista, the other will connect in Linux but not with winXP. I have the same problem with a 2wire router, Linux connects fine but XP won't.

    My personal thought is that the dhcp software on the router chokes when presented with a duplicate mac address from a different operating system and won't give out an IP address to the "foreign" system. Anyone have any thoughts on that?
  • darkixion
    darkixion Posts: 41
    I installed Ubuntu Studio on my cousin's laptop over the weekend, which is a Toshiba Satellite Pro, which has the Atheros chip set. I noticed it was marked down as an unclaimed device when running:
    lspci -v

    In the end I noticed that in the Hardware Drivers (under the System > Administration menu) there was something called Madwifi enabled. I disabled this, rebooted and it then worked fine. You might wish to check that you haven't also got Madwifi as the driver for your wireless adapter. If you still have problems, you may have to blacklist a driver to prevent it being used.


Upcoming Training