Welcome to the Linux Foundation Forum!

Issue with docker compose, section 6 -Launching Jenkins with Docker

Using a GCP instance, 18.04.1-Ubuntu
docker-compose version 1.17.1, build unknown
Client: Docker Engine - Community
Version: 20.10.14
API version: 1.41
when running 'docker-compose build" in the setup dir I receive this error.

ERROR: Version in "./docker-compose.yaml" is unsupported. You might be seeing this error because you're using the wrong Compose
file version. Either specify a supported version (e.g "2.2" or "3.3") and place your service definitions under the services
key, or omit the version key and place your service definitions at the root of the file to use version 1.
For more on the Compose file format versions, see

I reran by changing .yaml file version to 3.3 and all of the build steps occur up to 10 when the dockerfile tries to run the Jenkins plugin. Im assuming 1.24 is not compatible with ubuntu 18,04 but unsure.
jenkins-plugin-cli --plugins blueocean:1.24.3 is the line is fails on. Looking for some guidance

Comments

  • jhashem3
    jhashem3 Posts: 11

    I realized the image selected FROM jenkins/jenkins:2.263.1-lts-slim, needed to be updated to 2.271 based on the error. It went a step further but failed on the jenkins=plugin step.

  • jhashem3
    jhashem3 Posts: 11

    I got it working :) update dockerfile image to 'FROM jenkins/jenkins:2.277.4' and Jenkins-plugin to 1.23.2

  • luisviveropena
    luisviveropena Posts: 920

    Hi @jhashem3 , thanks for the information on the issue! I'll see if I can reproduce so I can report it.

    Regards,
    Luis.

  • luisviveropena
    luisviveropena Posts: 920

    Hi @jhashem3 ,

    The git repo has been updated and it's working now. So you can clean the browser's cache, and get the code again.

    Regards,
    Luis.

  • gouravshah
    gouravshah Posts: 95

    as @luisviveropena added, this issue, along with a few other setup related improvements are now gone into the upstream repo. If you pull the latest chages, recreate the setup repo, it should all be working with no changes in the lab instructions.

  • jhashem3
    jhashem3 Posts: 11

    thank you

Categories

Upcoming Training