Welcome to the Linux Foundation Forum!

Lab 2.2 - Failing to work

I have run through the aws setup.

I went through the setup steps depicted here.

Configured everything appropriately, including running swapoff -a; however, after I ssh into my instance and attempt to run the lab with this command bash k8scp.sh | tee $HOME/cp.out, I get the following output:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 buildah : Depends: crun (>= 100:0.18-3) but it is not going to be installed
 cri-o-runc : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1.5 is to be installed
 podman : Depends: crun (>= 100:0.19.1-1) but it is not going to be installed
          Recommends: containernetworking-plugins (>= 100:1.0.0-1) but it is not going to be installed
          Recommends: fuse-overlayfs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
sed: can't read /etc/containers/storage.conf: No such file or directory
Failed to enable unit: Unit file crio.service does not exist.
Failed to start crio.service: Unit crio.service not found.
Warning: apt-key output should not be parsed (stdout is not a terminal)

I'm running t2.large in AWS with 2 CPU, 8 GB RAM.
I'm able to SSH into my AWS instance.
I'm able to curl the project files in my AWS instance.
I'm not able to run bash k8scp.sh | tee $HOME/cp.out.

I have spent many hours attempting to run this lab in a variety of environments (virtual box, now AWS), all with the same result. I am absolutely spinning my wheels, any help would be appreciated as this is extremely discouraging..

Comments

  • The shell script provided targets a hardcoded Ubuntu version of 20.04. The AWS configuration video depicts Ubuntu 18.04. So, if a user follows along with the instructional video and configures their instance to use Ubuntu 18.04, they will need to also change the shell script to not use the hardcoded version, rather 18.04 (step 2, below).

    1. Pass --allow-downgrades to the apt-get-install commands for kubeadm, kubelet, kubectl, cri-o, cri-o runc, podman, and buildah like so:

    sudo apt-get install -y kubeadm=1.23.1-00 kubelet=1.23.1-00 kubectl=1.23.1-00 --allow-downgrades

    sudo apt-get install -y cri-o cri-o-runc podman buildah --allow-downgrades

    1. If you're using Ubuntu 18.04, update the following line within the k8scp.sh (~line 37):
      export OS=xUbuntu_18.04

    2. sudo -i

    3. k8scp.sh | tee cp.out

    4. sudo apt install docker.io

    5. export KUBECONFIG=/etc/kubernetes/kubelet.conf

    6. kubeadm join <IP:PORT> --token <TOKEN_HERE> --discovery-token-ca-cert-hash <SHA_HERE> --cri-socket /var/run/dockershim.sock

  • serewicz
    serewicz Posts: 994

    Hello,

    The course recently updated from U18.04 to U20.04. The videos have not yet been done. You can see this information by the date on the video. Please use U20.04.

    Regards,

Categories

Upcoming Training