Welcome to the Linux Foundation Forum!

9.2. Configure a NodePort Issue

Test access to thenginxweb server using the combination of cp URL [email protected]: ̃$ curl http://k8scp:321031<!DOCTYPE html>234Welcome to nginx!

This throws an error. Even though I have enabled all traffic and all previous steps ran without any error

curl http://k8scp:30385
curl: (7) Failed to connect to k8scp port 30385: Connection refused

Answers

  • joov
    joov Posts: 8

    Are you on AWS? please keep in mind to:

    • allow all traffic has to be the only rule for ingress traffic. If you have any other rules present they may be evaluated first and keep traffic from being forwarded
    • go to network interfaces -> actions and disable source / target checking

    I found this helpful.

  • You can ignore this..

Categories

Upcoming Training