Welcome to the Linux Foundation Forum!

labs on azure

Hi all,
I tried to run the labs on azure VM, but we found an issue w/ calico (see https://forum.linuxfoundation.org/discussion/855770/connection-timeout-connecting-from-worker-to-the-local-registry-running-on-master-via-clusterip#latest)
After some investigation and I very useful post on medium, I think I found a solution that I'm sharing through a github repo

I didn't run yet the full lab, but the main previous blocking point has been solved.
I hope that helps and please feel free to contribute to my repo to improve the current azure solution

@chrispokorni @tanwarsatya thanks for supporting me during the azure issue, hope that helps you as well

@serewicz feel free to share it with others

Comments

  • vasyhin
    vasyhin Posts: 15

    @crixo @chrispokorni I'm trying to configure my Azure k8s cluster...
    What I could find from all these links (what I need to change in Azure cluster created following the procedures described in the class Labs):

    • I need to use Canal instead of Calico
    • I need to create Azure Routetable
    • I need to add the following section
    networking:
     serviceSubnet: “10.240.0.0/16”
     podSubnet: “10.244.0.0/16”
    

    Is it the steps I have to perform? Cause I didn't find cleat steps I need to do to fix Azure issue w Calico.

  • vasyhin
    vasyhin Posts: 15

    Or the steps I need to perform are (from https://docs.projectcalico.org/v3.4/reference/public-cloud/azure)?

    Enable IP forwarding enabled in your VM network interfaces.
    
    On Kubernetes, also complete the following.
    Ensure that the selected pod’s subnet is a part of your Azure virtual network IP range.
    Include the name of your routing table in the configuration file of your Kubernetes Azure cloud provider.
    
  • crixo
    crixo Posts: 31

    Hi @vasyhin
    you should find all details on my repo at https://github.com/crixo/azure-kubeadm/blob/master/docs/azure-kubeadm.md
    The same github repo contains all scripts for azure resources provisioning and for configuring the cluster as described within the markdown file here above. You simply have to provide your own azure login account

    @vasyhin said:
    @crixo @chrispokorni I'm trying to configure my Azure k8s cluster...
    What I could find from all these links (what I need to change in Azure cluster created following the procedures described in the class Labs):

    • I need to use Canal instead of Calico
    • I need to create Azure Routetable
    • I need to add the following section
    networking:
     serviceSubnet: “10.240.0.0/16”
     podSubnet: “10.244.0.0/16”
    

    Is it the steps I have to perform? Cause I didn't find cleat steps I need to do to fix Azure issue w Calico.

  • vasyhin
    vasyhin Posts: 15

    Actiually my goal is not to simply get working env on Azure - but to understand what needs to be configured and why - to run k8s cluster on Azure VMs.
    @crixo I will try to use your script to instantiate VMs in Azure. But I still trying to figure out what parameters in your script allows VMs to communicate with Pods on other machines.
    Will let you know my results.

  • vasyhin
    vasyhin Posts: 15

    @crixo I've read https://docs.projectcalico.org/v3.6/reference/public-cloud/azure#about-calico-on-azure again. And now I see that there are 3 options how to configure Calico on Azure.
    I was trying to configure using Azure CNI IPAM plug-in (the simpliest I thought) - but still can't get it working.
    Which way do you implement in your github code? The first one? (Azure user-defined routes)?

  • vasyhin
    vasyhin Posts: 15

    FYI: created issue on Azure CNI plugin Github - to request help with plugin set up
    https://github.com/Azure/azure-container-networking/issues/333

  • vasyhin
    vasyhin Posts: 15
    edited April 2019

    @crixo Eventually I found the way to make it working. Option#2 (use flannel instead of calico) works well for me. Just followed the instructions. And how I can see now looks like your script uses canal.yaml as well (canal.yaml = flannel as I understood)

  • @vasyhin said:
    @crixo Eventually I found the way to make it working. Option#2 (use flannel instead of calico) works well for me. Just followed the instructions. And how I can see now looks like your script uses canal.yaml as well (canal.yaml = flannel as I understood)

    Thanks @vasyhin , this is what I did. Your post was really helpful in solving my problem, especially when I found this piece of code to get the CIDR block kubectl get nodes -o jsonpath='{.items[*].spec.podCIDR}'. Thanks :) David

  • We do not support labs running on Azure. Too many problems.

  • Just using CANAL instead of CALICO fixes the problems. I am delivering these courses on Azure almost all of the time. Reason for CALICO not working is that it requireres IPinIP encapsulation. You can get working on Azure, but that definetely takes some tweaking. Using CANAL, it will do CALICO over FLANNEL which works around the IPinIP requirement.

  • @vasyhin said:
    @crixo Eventually I found the way to make it working. Option#2 (use flannel instead of calico) works well for me. Just followed the instructions. And how I can see now looks like your script uses canal.yaml as well (canal.yaml = flannel as I understood)

    @vasyhin I am trying to do the same, but still cannot make it work. Can you provide information to me, whether you used the same pod CIDR as during definition of kubeadm-config.yaml, as during definition of calico.yaml (uncomment and edit CALICO_IPV4POOL_CIDR), as during definition of canal.yaml (uncomment and edit CALICO_IPV4POOL_CIDR)?

  • @adamkolarik said:

    @vasyhin said:
    @crixo Eventually I found the way to make it working. Option#2 (use flannel instead of calico) works well for me. Just followed the instructions. And how I can see now looks like your script uses canal.yaml as well (canal.yaml = flannel as I understood)

    @vasyhin I am trying to do the same, but still cannot make it work. Can you provide information to me, whether you used the same pod CIDR as during definition of kubeadm-config.yaml, as during definition of calico.yaml (uncomment and edit CALICO_IPV4POOL_CIDR), as during definition of canal.yaml (uncomment and edit CALICO_IPV4POOL_CIDR)?

    Finally I succeded with deployment, it was not easy to get rid of calico deployment, simply only kubectl delete -f did not help me.
    I had to follow instructions https://stackoverflow.com/questions/61672804/after-uninstalling-calico-new-pods-are-stuck-in-container-creating-state, so after delete file, then restart nodes, then apply canal.yaml (with uncomment and edit CALICO_IPV4POOL_CIDR) solved my problem.

  • Some clearer notes that may help some people. I got this to work on Azure today by switching out the Calico setup for a Flannel + Calico setup (also known as Canal), since the default Calico setup does note work on Azure.

    General instructions can be found at https://projectcalico.docs.tigera.io/getting-started/kubernetes/flannel/flannel

    To make this work with the labs, change the master node set up as follows BEFORE running k8scp.sh. You will need to go into the lab folder LFD259/SOLUTIONS/s_02 and make some changes:

    • Note the lab files set up a pod cidr of 192.168.0.0/16. You can see this in the lab exercise files; see contents of LFD259/SOLUTIONS/s_02/kubeadm.yaml to find this, it's near the end.

    • Download canal.yaml with wget https://docs.projectcalico.org/manifests/canal.yaml - this URL obtained from the general instructions linked above.

    • Edit the canal.yaml - you are looking to uncomment the setting of the CALICO_IPV4POOL_CIDR variable to match what was in kubeadm.yaml. For me the comment already included the correct CIDR. At the time of writing, the setting is on lines 4198-4199 of the file.

    • Edit k8scp.sh; find the line that applies the calico.yaml to apply to edited canal.yaml instead. e.g. Change it from kubectl apply -f https://docs.projectcalico.org/manifests/calico.yaml to kubectl apply -f canal.yaml. Note you'll need to run k8scp.sh from the s_02 folder now to pick up canal.yaml - don't copy it to the home folder like in the lab notes.

Categories

Upcoming Training