Welcome to the Linux Foundation Forum!

Lab 2.2-2.3 DNS Loss

Issue:
When following the steps of this course to setup kubernetes cluster, the VM's are sabotaged by the scripts provided by this course, which damage/disable default DNS.

Steps to replicate:
-Setup VM's in designated environment (Ubuntu 18.04)
-VM's have good DNS, can ping www.google.com or each by master / minion hostname
-Run scripts for LFD259/SOLUTIONS/s_02/k8sMaster.sh and k8sSecond.sh to setup master and minion nodes
-No DNS

At this point I lose all DNS, preventing any further use of the course. I cannot get the Nginx image in lab 2.3 because that will not communicate with the image repository. I'm really not sure what to do to further investigate this or what is triggering this issue and would appreciate assistance.

Comments

  • Hi @nkerr,

    Where are you setting up your VMs - which cloud or which local hypervisor are you using for the lab environment?

    Regards,
    -Chris

  • nkerr
    nkerr Posts: 10

    Hi @chrispokorni,
    The VM's are setup on VMware esxi 5.5

  • Hi @nkerr,

    The installation and cluster bootstrapping scripts are not modifying the host DNS configuration. I am assuming that Calico may have something to do with that, instead of Kubernetes itself.

    1. Can you compare the /etc/resolv.conf of a new host (pre-install) with a node (post-install)? Does adding the missing/removed config options help fix your DNS?
    2. Also, there is an earlier discussion in the forum which may also help.

    Regards,
    -Chris

  • nkerr
    nkerr Posts: 10

    @chrispokorni
    Thanks for your response. There is no change in the /etc/resolv.conf file before/after installation.
    To correct my initial statement, it seems installation doesn't have an effect, after further testing the DNS doesn't fail until I run the kubeadmn join command.
    I am still investigating regarding the other discussion you mentioned.

  • nkerr
    nkerr Posts: 10

    @chrispokorni
    The earlier discussions conclusion regarding Switching from IP-in-IP to VXLAN seems to have resolved everything. Thanks again.

  • fredlev
    fredlev Posts: 2
    edited June 20
    please delete . thx
    

Categories

Upcoming Training